Error while creating ZOOM Meeting

We try to call ZOOM Meeting to create an API call and we get the following error.

An unexpected error occured while attempting to move the activity to production. The activity was not created or updated on the Zoom server. please try again later or contct your system administratot. Error code(300): Invalid enforce_login_domains, please seperate multiple domains by semicolons ".

How To Reproduce
Please note that this is unique to few customers who are facing this problem. We are available for a call to demo the issue.

Attached is the error we receive while doing the create call from our application.

@sai11101989 are you the developer in the app? If seems they have not configured the enforce_login domains part correctly.

How to do it correctly? Can you share some resources? We see that this flag is being deprecated. We can have a short call with my developer if you are available today as per your availability.

It seems that the error message is related to the “enforce_login_domains” parameter of the API call, which is used to restrict login to specific domains. The error message indicates that there is an issue with the way this parameter is formatted.

To fix the issue, ensure that the “enforce_login_domains” parameter is properly formatted and that multiple domains are separated by semicolons. Double-check that the domains you are specifying are valid and have been properly authorized on the Zoom server.

This is what we pass: “enforce_login_domains”: “false”. If you look at the below JSON we use, we send unique values wherever the values are under %%, the blank fields are left blank.

“topic”: “%ActivityName%”,
“type”: 2,
“start_time”: “%StartDate%”,
“duration”: “%Duration%”,
“timezone”: “%TimeZone%”,
“agenda”: “%ActivityDescription%”,
“settings”: {
“host_video”: “false”,
“participant_video”: “false”,
“cn_meeting”: “false”,
“in_meeting”: “false”,
“join_before_host”: “true”,
“mute_upon_entry”: “false”,
“watermark”: “false”,
“use_pmi”: “false”,
“approval_type”: 0,
“audio”: “both”,
“auto_recording”: “%RecordingType%”,
“enforce_login”: “false”,
“enforce_login_domains”: “false”,
“alternative_hosts”: “”

This issue is limited to a few customers only. However, when testing the issue using our own Zoom account, we couldn’t reproduce the issue. To add we never changed our implementation since day 1 and a few customers recently started reporting issue.

Is there something that needs to be reviewed from our customer ZOOM account settings? If yes, what needs to be checked?