Failed to join meeting with Zoom Web SDK after migration from JWT app type

Description
We are using the Zoom Web SDK to have our clients joining Zoom meetings. Our scenario is as follow:

  1. Client A is invited by Client B to a meeting.
  2. Client A is using the Zoom Web SDK to join. Client B doesn’t have our Zoom app installed on the account (previously JWT app and now Zoom SDK app)
  3. Client A will join the call with limited functionality but it will work.

This was working exactly as expected when using the JWT app type for the Key/Secret. We just migrated to the new Zoom SDK app type as required to move passed the deprecation and update to the SDK version 2.7.0.

It just doesn’t work anymore with the Zoom SDK app type. Our error is that the signature is incorrect but if while testing I have Client A creating the meeting and joining its own meeting via the Web SDK it will just work.

I have been crawling through the documentation without finding any information about it, would you be able to help?

Note: We are using role 0 to join the meeting

Error?
{type: ‘JOIN_MEETING_FAILED’, reason: ‘Signature is invalid.’, errorCode: 3712}

Which Web Meeting SDK version?
2.6.0
Just tested with 2.7.0 and I see the same issue.

How To Reproduce

  1. Build SDK APP (Intend to publish: Yes) / Keep it’s not published yet.
  2. Generate signature and join meeting with a meeting number created by not the developer account.
  3. You will get error described.

Additional Contexts:
Our application is not published yet.

I tested with the Meeting SDK Sample and I get the same error.

have you updated your parameter in ZoomMtg.join ?

for JWT Signature :

    ZoomMtg.join({
          signature: signature,
          apiKey: ... ,

for SDK JWT Signature:

      ZoomMtg.join({
          signature: signature,
          sdkKey: ... ,

Hi,

yes I updated it. I believe that the Zoom Meeting SDK would not even work as the apiKey parameter has been removed.

If in my example Client A who has the App on his account try to create a meeting then we will be able to join via the WebSDK it works, which leads me to believe we are using the right keys :thinking:

create a new simple test meeting

  • Registration not required
  • a simple Passcode
  • no waiting room
  • Options: Allow participants to join anytime

try the current version of SDK Web Sample V2.7.0 (-> CDN Version)

5 lines changed

index.js:

20: var SDK_KEY = ...
26: var SDK_SECRET = ...
112: var joinUrl = "meeting.html?" + testTool.serialize(meetingConfig);

meeting.js:

31: leaveUrl: 'index.html',
63: externalLinkPage: 'externalLinkPage.html',

does it works with your Meeting SDK App?

Hi, we still get the same error.

The fact that our SDK app is not published should not change anything right?

if I had created the SDK app in June, it worked immediately

is your app activated?

this is the state of my working app
zoom-app

Thanks for the reply.

Right now that’s how it looks for us:

The top one is the new one I am using that is having issues. The second on is the JWT that used to be working. How do you get from draft to activated? Could this be the issue?

To sumarize again:

  • If I create a meeting from our Airtame organisation and try to join the meeting from the Zoom Meeting Web SDK it works both with Role 0 and 1;
  • If I create a meeting from outside the organisation (with a personal account) and try to join the Zoom Meeting Web SDK with role 1 it fails as expected;
  • If I create a meeting from outside the organisation (with a personal account) and try to join the Zoom Meeting Web SDK with role 0 it fails but shouldn’t;

the different - my app is not Indent to publish → so it was activated immediately and Live on account

Yeah this is what I noticed too. We will try to get ours approved to see when not draft if it works better I guess :thinking: Thank you for your help.