❌ failed to subscribe to raw audio with status 32

zoomsdk-1 | :white_check_mark: configure
zoomsdk-1 | :white_check_mark: initialize
zoomsdk-1 | :white_check_mark: authorize
zoomsdk-1 | :white_check_mark: join a meeting
zoomsdk-1 | :hourglass_flowing_sand: connecting to the meeting
zoomsdk-1 | :white_check_mark: connected
zoomsdk-1 | errorrs 12
zoomsdk-1 | :hourglass_flowing_sand: requesting local recording privilege - 1
zoomsdk-1 | errorrs 0
zoomsdk-1 | :white_check_mark: start raw recording
zoomsdk-1 | :x: failed to subscribe to raw audio with status 32

i am getting this error on this repo

so i went for another repo which is this

however, i am getting error of authentication hence callback function to join meeting was not being able to call.
Please help me or let me know if you guys have been working on this. Cause i don’t waste my time trying to solve since i have given 3 days on it.

same error .

@kamalkumar77a ,

Thank you for reporting this! What version of the Linux SDK did you download and paste into the Lib/zoomsdk folder?


this is latest one

@kamalkumar77a have you checked out this ?

I followed these steps but encountered the same error. I’m using an AWS EC2 instance to execute these steps. Initially, I copied the files and configured the config.ini file on my local system(linux), then transferred the entire folder to the EC2 instance. Afterward, I created an image and used Docker Compose, but encountered an error.

@donte.zoom @chunsiong.zoom

Have you guys been working on it? I need to use this in production side.
@management1 got the same error.

@kamalkumar77a Im the maintainer for GitHub - zoom/meetingsdk-linux-raw-recording-sample. I’ve just tested this and this works fine

Please note that sample codes are sample codes. They are quick guides on how to achieve specific scenarios.

They are not meant for direct use in production as they do not catch all states and exceptions

Can you explain how did you do that ?

meeting_number: “87475456334”
meeting_password: “6KXq53”
GetVideoRawData: “true”
GetAudioRawData: “true”
SendVideoRawData: “false”
SendAudioRawData: “false”

i am using this an config.txt.

I made signature using this code.

const generateSignature = () => {
const iat = Math.round(new Date().getTime() / 1000) - 30;
const exp = iat + 60 * 60 * 2;
const oHeader = { alg: “HS256”, typ: “JWT” };

const oPayload = {
  sdkKey: apiKey,
  appKey: apiKey,
  mn: "86450336733",
  role: 0,
  iat: iat,
  exp: exp,

const sHeader = JSON.stringify(oHeader);
const sPayload = JSON.stringify(oPayload);
const sdkJWT = KJUR.jws.JWS.sign("HS256", sHeader, sPayload, apiSecret);
return sdkJWT;


I can see i got something here
if ((err = m_pAuthService->SetEvent(new AuthServiceEventListener(&OnAuthenticationComplete))) != SDKError::SDKERR_SUCCESS) {};

as i was unable to get in this
OnAuthenticationComplete callback function.

I won’t use it on production directly. However, i will do it on locally since it is task which i have to complete.

@kamalkumar77a can you try it without recording token?

If your docker build process takes more than 120 seconds, the recording token will expire.

Hey, everything works well now. However, recording didn’t started because i haven’t
done any of this
Once you have successfully joined a meeting, subscribing to raw audio and raw video requires either

  1. either host/co-host/local-recording rights or
  2. meeting recording token

can you tell me what does this mean ?


mn should not be in quotes
You are also missing tokenExp

I sent that as an example. anyway it’s working fine just let me know about recording.

Participants count: 2
Cannot start raw recording: no permissions yet, need host, co-host, or recording privilege

getting this error

  1. either host/co-host/local-recording rights or
  2. meeting recording token

@kamalkumar77a This means either you are a host, co host, or given recording rights by the host.

If you just join the meeting, you will just have participant status.
Participants are not allowed to record without permission from host.

During meeting you can request host to give you host / co-host / recording permission.

There is also recording token, which is a special token which you can use when you are joining the meeting. Having a valid recording token will grant you recording permission without additional request to host.

How can i get recording token?

I tried documentation to get audio recording token. Used oAuth 2.0 to access token.

I think i am missing in giving correct credentials.
here is this

If you are doing your own testing for your own account, you can get the recording token by create a server to server oauth app, and using calling the API below.

Another way is just to click on the user from your zoom client, and give recording permission