Format json returns onUnsupported Command


For some reason I get ‘onUnsupported Command’ when sending ‘format json’ from my SSH Client. All other commands work as expected.

If I use Putty I can send the format json command with no problems. Are there any log files that I can look at to see what the ZR is receiving and why it’s not recognising the command?

I’m using Beta14 on Mac.



It looks like the problem is that for this command, you can’t have any additional whitespace or unusual carriage returns before, within, or after the command. Check to make sure that the line you send to the API is “format json\n”, without any other spaces or carriage return codes. I used PuTTY on Windows, and using the default settings, it works.


Yeah when I use putty it also works perfectly for me too so it must be something that happens within my SSH client, but I’m really struggling to see what the problem could be. Very strange.

Is it possible to run that command from a script? Or is there another way to force the API to JSON rather than CLI on startup? Once I’ve logged in via putty and enabled JSON everything else works fine. So I really just need a way to ensure that the format is always JSON.



I do not have a solution for this problem in the beta 14; I will add code to the next build that accommodates white space around the command.


I’m not entirely convinced that’s what the issue is as I’m sending the command from .NET and trimming all white space from start and end of the string. Without seeing what is received at the ZR side I can’t say for certain though.

If possible it would be great to have the format non-volatile, ie. set it to JSON once and it will remain that way after a reboot. Is that something that czn be achieved?

Also, to ask the question again; is it possible to run that command from a script?

Thanks for the support!


It’s not possible to include the format command in a script; the format command is handled at an early stage, and script text is not fed to that stage of the parsing.



@aWhitehouse, We have fixed the problem in beta 15. It is currently available at


Thanks Zach. I have just had chance to test this with beta 16 and can confirm it’s working.