New SSH connection refused if client disconnects uncleanly

#1

Hi.

In October 18’, Jeffery Thompson reported some issues with reconnecting to the ZR-CSAPI if there was an unclean disconnect (e.g Power loss to the client). I’m still experiencing this issue in Zoom Rooms 4.3.2. In my case the only way to get the ZR-CSAPI to accept new connections is to restart the Zoom Room App. It worries me that this still haven’t been solved after 7 months as the current implementation i’m working on is to be installed on a large number of classrooms and auditoriums at a University. Are you working on solving this issue?

  • Vidar
1 Like
#2

Vidar: Is that a Windows or Mac Zoom Room? I’ll try to reproduce it. We were not previously able to reproduce the problem.

#3

Zoom Rooms 4.3.2 running on a clean Windows installation.

#4

I just did some quick testing, and it seems to happen if format is set to json. I did the following test:

  • Open a ssh client on my computer
  • Connect to ZR-CSAPI
  • Disconnect the network cable from the computer running the ssh client.
  • Close ssh client
  • Reconnect network cable
  • Open client and connect.

With this procedure, i was able to reconnect, but if i enter “format json” before i disconnect the cable, i was not able to reconnect unless i restarted Zoom Rooms. Hope this helps you to reproduce the problem.

#5

Vidar: We’re having difficulty reproducing the problem. Which SSH client where you using ? PuTTY on Windows, or command line on windows?

#6

The issue was first noticed when using Crestron, but to be sure this wasn’t a Crestron issue, i tried with both putty and MobaXterm. I don’t know what steps you are doing to reproduce this issue, but are you sure you’re not connected to wifi on the client computer at the same time when pulling the ethernet cable during the testing? In that case the SSH client would send a disconnect message to the SSH server, and the issue would not occur. The issue is easily reproduced on my end.

#7

Hi Vidar, Scott,
I got that error while incorrect connecting attempts to ZRAPI from python - SSH login from nodejs/python .
API proccess takes about 27% of CPU for a long time and won’t allow to connect again until restart zoomroom App.
Looks like ZRAPI waits for socket data, cannot destroy socket and refuses any connections.
Now the installation works stable with correct python/ssh implementation, but I think the issue is still here.

#8

Hi all,

I have passed this issue to our ZAAPI engineering team. They are currently investigating.

#9

Any news from the ZAAPI engineering team? I did some more testing and the issue does occur even when not entering “format json”, so ignore my previous statement regarding this. As to CPU usage, i do not see any increase in CPU usage on the Zoom Room PC when the issue occurs.