Framereader read null frame! (Videos are no longer appearing in Chrome)

Description
I have Chrome v94 and I have updated the zoom web meeting SDK to 1.9.9.
But I’m not able to see my or anyone else’s video. Why?

Which Web Meeting SDK version?
I’m using 1.9.9.

Device (please complete the following information):

  • Device: System
  • OS: Windows
  • Browser: Chrome
  • Browser Version: 94.0.4606.71

Additional context
Please help me. This is very very important.

Greetings, @ritu.munday,

Welcome to the Developer Forum-- I am happy to help ! As a start, can you share a screenshot of the browser console when you are seeing this behavior ?

It sounds like you may be encountering a Web page Cross-Origin Isolation issue, have you tried using SharedArrayBuffers origin trial in your application? Here is our help documentation which provides step-by-step implementation guidance:

Let me know if you have any questions about this – I will keep an eye out for your reply!

Best,
Donte

Hi @donte.S

Please find below the screenshot.
The error in the screenshot below keeps on increasing.

When I added SharedArrayBuffers origin trial, the outcome is that the host can see my preview but I do not see my own preview.
Please help with either way.
We want to see others videos and show my own video too.

Hey @ritu.munday ,

Few things to check.

  1. Make sure your CDN or Local Assets are also on the same 1.9.9 version, example.

  2. Make sure you have implemented Cross Origin Isolation or the SharedArrayBuffer Chrome Origin Trial.

Thanks,
Tommy

Hi @tommy

I have made sure that I have

  1. All the versioning to be 1.9.9. (Somewhere it was different, thanks for that.)

  2. I have added SharedArrayBuffer Chrome Origin Trial. (This was already there.)

Now, the host can see my preview but I can’t see my own preview.
What should I do about that?

Hey @ritu.munday ,

That is great, we are making progress. :slight_smile:

Can you share a screenshot of this?

Thanks,
Tommy

The same thing happens to me, as a host I can’t see my preview but only the participant.

Solved for me on browser laptop. The problem persist when try to make zoom meeting on phone device.

Hey @lucian.tanase,

Unfortunately, mobile browsers are not supported at this time. We are always working to expand our platform support though.

Please see our changelog in order to stay up-to-date with the latest features and fixes. You can also subscribe to the latest news at developers.zoom.us.

Thanks,
Max

Hello @tommy
I have the same issue.
I am using zoom web sdk 2.0.1, Windows and MacOS Chrome 95
Would you please help me?
Best regards

Greetings, @jameschan0524,

Happy to help ! Can you verify if you have implemented Cross Origin Isolation or the SharedArrayBuffer Chrome Origin Trial ? You can verify that the changes were applied to your site by entering the following in your browser console:

Also, I should note by default if you navigate to http://localhost:9998 it is enabled :

Vs.

Let me know if this helps.

Best,
Donte

Thanks for your reply. @donte.S
Yes, already I have configured origin-trial and it says TRUE. but no work
Thanks

Hi, @donte.S

I am not sure this caused my issue.
Would you please check this code?

if n.format is not “I420” or “NV12” then I am getting invalid i.format.
I guess, i variable should have a default value.

The format can be “I420A” or “I420P”.

Regards

1 Like

I have similar issue as well. Please let me know if you found any solution/workaround for this issue

@jameschan0524 ,

Thank you for providing those details. Can you share screenshot of your join function and also verify the following:

  1. Make sure your CDN or Local Assets are also on the same 2.0.1 version and you are calling the following methods at the top of the page like this example :

Best,
Donte

Hi,

Thank you for writing us, @saravana! It sounds like your camera requires a certain format. To ensure the best support, we will need more information pertaining to your camera setup along with details about the framework you are using ?

This information will help us provide more personalized support as well as debug the behavior you’ve encountered.

Best,
Donte

@donte.S My application uses React 17.0.2 and Zoom Web Meeting SDK 2.0.1. The video stream comes from Canvas HTML element as the application needs to send the custom rendered video from the browser to the Zoom meeting. It is similar to a camera video feed.

Stream (Camera or Canvas) continuously sends video frames(think of them as series of images) to the video or meeting. Images are in different formats like png, jpg, gif, etc, similarly VideoFrames might be in different formats. Zoom supports only two formats “I420” and “NV12”. The video frame format sent by Canvas stream is of format “I420A”. It is similar to I420 format, but with additional alpha channel.

The zoom meeting video issue that I have and @jameschan0524 mentioned in the earlier post are same.

This is not the issue with Zoom version, but the video frame formats that is supported by Zoom. His screenshot clearly explains the issue. I hope this explains the issue. Does Zoom has any plan to support formats other than I420 and NV12 in Web SDK ?

@donte.S
Same here, I used canvas for the video stream, I need to customize the video stream on the canvas and send it to zoom.
Please help us with this issue.
Thanks

@donte.S how are you?
Any luck?
Teams, Google Meet, Skype, Whereby does support I420A
Only I have an issue with Zoom and this was work perfectly on 1.9.7
Would you please help me? or please let me know what is the workaround.
Best regards

Greetings, @saravana and @jameschan0524,

It looks like you are trying to modify the function in the Web SDK library to send the custom rendered video from the browser to the Zoom meeting. Is this accurate? If so, that workaround is not supported for the Web SDK which is why you are seeing that behavior.

Alternatively, to achieve the user experience you are envisioning, our new Video SDK allows you to build highly customized user interfaces along with access to raw video and audio data. You will need a separate email account to get started, as no other Zoom services can reside on it. You can sign up for a new Video SDK account here. Please note, 10,000 mins/month are free and the plans are pay as they go.

Please let me know if this helps.

Best,
Donte