Getting glitchy/patchy audio using Android SDK

After a few seconds, to a few minutes, the Zoom audio gets incrediably patchy and glitchy - maybe half a second in 10 seconds. It seems to match getting “W/AudioTrack: releaseBuffer() track 0xc0a87d80 disabled due to previous underrun, restarting” lines in LogCat.
Rather bizarelly it seems to be related to the amount of audio being transmitted. If I run the meeting with my iPhone as host and just listening to my keyboard clacking and mouse clicking then I get no issues.
I have setup my phone next to a radio in another room, and now can reproduce the issue within minutes.
If I leave the Zoom meeting like this then after a while our entire Android app crashes out as I guess Android has had enough of the buffer underruns.
I have another Android tablet connected to the same Zoom meeting so I am basically listening to the radio via two tablets - one running the “Zoom SDK Demo” app (fine) and our app (not so fine!)

So it appears that somehow I am getting a buffer underrun in the Zoom audio. But I cant find (yet) any other references to this on the devforum.

Which version?

To Reproduce(If applicable)
Really hard to say.

If applicable, add screenshots to help explain your problem.

Smartphone (please complete the following information):
Android 9 on a Galaxy Tab A 2018 model tablet.

And I mean getting 1/2 sec of audio in 10 secs. So 9.5 secs are silent

Hi @egon, thanks for using the dev forum.

Sorry to hear you are running into issues with meeting audio. This would definitely be the first I’m hearing of this problem. Let’s take some troubleshooting steps and then get some additional information if the issue persists.

  • Is this issue still present on the latest version of the SDK?
  • Can you reproduce this in the Zoom client as well, or is it only happening with the SDK?
  • If the device is moved further away from the router it is connected to, the chances of data not being sent increases. Please ensure that your device is close enough to your router that this is not an issue.

If it is still not working after trying these steps, the following information will allow us to investigate further:

  • Have you noticed any loss in video data as well, or is it only audio data?
  • Please send device logs to and mention this thread.
  • Can you please provide the crash log as well?


Had a bit of trouble getting the latest SDK to work. Will give that another go tomorrow my time (end of day here)

Issue doesnt occur in the offical Zoom app. Left it running for 10 mins with no issues (as expected)

Not a Wifi issue. Have 200 mbps internet and the Android tablet Wifi is connected at 130 mbps.

Havent noticed a video glitch. Will rig up the phone (meeting host) to point at the TV tomorrow to test.

I have been trying to export the Zoom log file mentioned at the bottom of
I dont have that file path showing in the Device File Explorer in Android Studio. I do have a /data/data/com.mycompany.myapp/ folder but I dont have a /log directory in there so I cant get that to you.

I am init’ing the SDK using the below code so would expect the log file to appear. Am I looking in the right location?

ZoomSDKInitParams initParams = new ZoomSDKInitParams();
initParams.appKey = SDK_KEY;
initParams.appSecret = SDK_SECRET;
initParams.enableLog = true;
initParams.enableGenerateDump = true;
initParams.logSize = 50;
initParams.domain = AuthConstants.WEB_DOMAIN;
mZoomSDK.initialize(context, this, initParams);

Will get some logs across tomorrow my time

Hi @egon, thanks for the additional info.

I dont have that file path showing in the Device File Explorer in Android Studio

Have you also tried looking in sdcard/Android/data/${PACKAGE_NAME}/logs?

Havent noticed a video glitch. Will rig up the phone (meeting host) to point at the TV tomorrow to test.

Thank you. This, along with the internet speeds you are reporting, will confirm whether or not there is an issue with connectivity. Since the type of streaming used by Zoom requires a UDP connection, network stability can play a major factor in scenarios like this. A speed of 130mbps is more than fast enough, but there may be more than just speed at play here.

Had a bit of trouble getting the latest SDK to work

Please let me know if there is anything I can do to help out on this end. :slightly_smiling_face:


Emailed the Zoom logs to the email address requested. Hopefully that helps.

As additional info, when the “W/AudioTrack: releaseBuffer() track 0xc3b98400 disabled due to previous underrun, restarting” start becoming more frequent (at least one a second) the video lags as well.

Hi @egon,

Thank you for sending the logs over, I can confirm that we have received them. We will need to investigate this and let you know our findings. In the meantime, please don’t hesitate to reach back out if you need help with anything else. :slightly_smiling_face:


Currently watching TV downstairs on the tablet upstairs using Zoom. No loss of picture (apart from the odd slow down/speed up). Only audio that is dropping out completely

Hi @egon,

Thank you for checking in on that. I will make note of this while we investigate further.


Looks like the latest SDK fixes it. Been running 20 mins with no issues.

Thanks for the help! Much appreciated

Glad to hear this is resolved in the latest SDK!

Don’t hesitate to reach back out for assistance with any other issues.