Getting NULL response when create meeting using api in android sdk

Description
Hi Sir,
JWT token generated successfully using android SDK key and secret
and then using this token creating meeting.
Platform: Android Studio
Language :java
i am passing this token as a Header parameter in api like,

Authorization: Bearer jwt token
Content-Type: application/json

and other parameters of Create Meeting using POST Method

POST /users/{userId}/meetings

but getting NULL Response

trying /users/me/meetings and /users/emailid/meetings also getting blank response
Error
The full error message or issue you are running into.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

Which Endpoint/s?
post # /users/{userId}/meetings

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Request URL / Headers (without credentials) / Body
  2. See error

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
Add any other context about the problem here.

Hi @gms ,

To make a request to the Create a Meeting API endpoint with the Android SDK you have to actually create a JWT app and use that App Key & App Secret to generate a token. Then use that token to make a CREATE request :slight_smile:

Thank you,
Gianni

Hi @gianni.zoom,
Thank you for your reply,
i am using zoom meeting SDK app for android
As you suggested,i am created JWT app and generated token using API key and secret and this token used for CREATE Meeting but getting null response.
Please Reply ASAP

Thank You.

Hi @gianni.zoom,
Please Reply.

Thank You

Hi @gianni.zoom,
as you suggested , i am used API key and secret for generating JWT Token
and used in create meeting api but getting null exception and
when i checked in postman getting 400 bad request
Please Please Reply

Thank You

Hi @gianni.zoom ,
Meeting created successfully thank you for your reply,
but now getting new problem ,in create meeting response- start time not showing correct time.
in my zoom profile account showing GMT+5:30
start time using below format:
start_time(yyyy-MM-ddTHH:mm:ssZ)
or
start_time(yyyy-MM-ddTHH:mm:ss)
timezone(Asia/Calcutta)

please reply

Thank You

Hi @gms,

Glad you were able to create the meeting successfully. What is the time in the response body you’re seeing please?

Thanks,
Gianni

Hi @gianni.zoom,
I am not setting current time in start_time
setting any time after 2 or 3 hours from Current Time or next day

i am setting time like : 2021-11-24T07:30:00Z
getting response like
Created At : 2021-11-24T11:45:48Z
Start time L 2021-11-24T11:45:48Z

Please Reply ASAP

Thank You

Hi @gianni.zoom,
I am not setting current time in start_time
setting any time after 2 or 3 hours from Current Time or next day

i am setting time like : 2021-11-24T07:30:00Z
getting response like
Created At : 2021-11-24T11:45:48Z
Start time L 2021-11-24T11:45:48Z

And i am using Meeting SDK for Android Mobile
in that how to save Audio Recording in Local

Please Reply ASAP

Thank You

Hi @gianni.zoom,

Please Reply

Thank You.

Hi @gms,

Can you please share a screenshot of the time section of your request body? Is the value for time an integer or string? For example:

"start_time": "2019-08-30T18:00:00" (correct) vs/ "start_time": 2019-08-30T18:00:00 (incorrect)

Try updating the meeting you’ve created: https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingupdate.

Thanks,
Gianni

Hi @gianni.zoom,

In request body sending “start_time” :" 2019-08-30T18:00:00" as a String.
Please Reply ASAP

Thank You.

Hi, @gms,

If you are including the Z in the start_time, it will be sent with GMT time and not your timezone. Try removing the Z.

Creating Meeting API link :

Best,
Donte