Host video and audio are not on when create zoom meeting create api

API Endpoint

We are making an application with zoom meeting apis using server to server auth.
Users can make an reservation then our system create a zoom meeting by api.
The user will be participants and tutor will be host of the meeting.

The issue is that both video and audio of the host are off when start a meeting,
however no problem with participants.
I want that when the host enter the meeting, both audio and video are set on automatically.
How to solve this?

Authentication method or app type
Server to Server Auth

Code of meeting detail

details = {
    "agenda": zoom_meet_detail.agenda,
    "topic": zoom_meet_detail.topic,
    "duration": zoom_meet_detail.span,
    "timezone": "",
    "start_time": zoom_meet_detail.start_datetime,
    "type": 2,
    "settings": {
        "allow_multiple_devices": True,
        "audio": "both",
        "auto_recording": "local",
        "calendar_type": 2,
        "email_notification": True,
        "host_video": True,
        "join_before_host": False,
        "meeting_authentication": True,
        "meeting_invitees": [
                "email": zoom_meet_detail.student_email
        "participant_video": True,
        "private_meeting": True,
        "registrants_confirmation_email": True,
        "registrants_email_notification": True,
        "waiting_room": True,
        "alternative_host_update_polls": True,
        "show_share_button": True,

Meeting Id

Thanks for any help

What you are getting in response?

It’s the response for the above meeting id

‘uuid’: ‘2qLvw9sHQkGvPf7uTHH44g==’,
‘id’: 86335570513,
‘host_id’: ‘vrQY67tlRSe9onjbEzbUoA’,
‘host_email’: ‘’,
‘assistant_id’: ‘’,
‘topic’: ‘Coffe D. Shim_ 30 Minute Class’,
‘type’: 2,
‘status’: ‘waiting’,
‘start_time’: ‘2022-12-30T14:00:00Z’,
‘duration’: 30,
‘timezone’: ‘Asia/Seoul’,
‘agenda’: ‘2. If Clause Part 2’,
‘created_at’: ‘2022-12-27T06:19:42Z’,
‘start_url’: ‘’,
‘join_url’: ‘’,
‘password’: ‘G8G3GG’,
‘h323_password’: ‘366774’,
‘pstn_password’: ‘366774’,
‘encrypted_password’: ‘TWFZQnhoM3hJOFJMZ2xyVkh0R1N5QT09’,
‘settings’: {
‘host_video’: True,
‘participant_video’: True,
‘cn_meeting’: False,
‘in_meeting’: False,
‘join_before_host’: False,
‘jbh_time’: 0,
‘mute_upon_entry’: False,
‘watermark’: False,
‘use_pmi’: False,
‘approval_type’: 2,
‘audio’: ‘both’,
‘auto_recording’: ‘local’,
‘enforce_login’: True,
‘enforce_login_domains’: ‘’,
‘alternative_hosts’: ‘’,
‘alternative_host_update_polls’: False,
‘close_registration’: False,
‘show_share_button’: False,
‘allow_multiple_devices’: False,
‘registrants_confirmation_email’: True,
‘waiting_room’: True,
‘request_permission_to_unmute_participants’: False,
‘registrants_email_notification’: True,
‘meeting_authentication’: True,
‘authentication_option’: ‘signIn_bcxFGfu5T-ecBRfslUsGmw’,
‘authentication_name’: ‘Zoom에 로그인’,
‘authentication_domains’: ‘’,
‘encryption_type’: ‘enhanced_encryption’,
‘approved_or_denied_countries_or_regions’: {
‘enable’: False
‘breakout_room’: {
‘enable’: False
‘alternative_hosts_email_notification’: True,
‘device_testing’: False,
‘focus_mode’: False,
‘enable_dedicated_group_chat’: False,
‘private_meeting’: False,
‘calendar_type’: 2,
‘email_notification’: True,
‘host_save_video_order’: False
‘pre_schedule’: False

You need to enable host video from settings → schedule settings → Host Video


For more on how to create Zoom Meeting and more → here.

This did not solve the issue for me, did it work for OP?