How can I get participant_audio_files?

Description
I found payload.object.participant_audio_files is added in document below

But I cannot recieve participant_audio_files.
I expect this attribute provide sepatate audio file per participant.

Can I get this atrribute with Cloud Recordings Webhook?

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Webhook

Screenshots (If applicable)

Document shows participant_audio_files.

Additional context

I just got response body below. missing participant_audio_files.

{
    "payload": {
        "account_id": ""{XXXX concealment XXXX}"",
        "object": {
            "uuid": "uv6rVVk0SeSh+EIDMS9qSg==",
            "id": 89974779408,
            "account_id": ""{XXXX concealment XXXX}"",
            "host_id": ""{XXXX concealment XXXX}"",
            "topic": "Zoom meeting invitation",
            "type": 2,
            "start_time": "2021-07-29T03:25:15Z",
            "timezone": "Asia/Tokyo",
            "host_email": ""{XXXX concealment XXXX}"",
            "duration": 0,
            "total_size": 379457,
            "recording_count": 2,
            "share_url": ""{XXXX concealment XXXX}"",
            "recording_files": [
                {
                    "id": "99b86892-8b03-47d1-8787-fed2ebc3032b",
                    "meeting_id": ""{XXXX concealment XXXX}"",
                    "recording_start": "2021-07-29T03:25:24Z",
                    "recording_end": "2021-07-29T03:25:35Z",
                    "file_type": "MP4",
                    "file_extension": "MP4",
                    "file_size": 204042,
                    "play_url": ""{XXXX concealment XXXX}"",
                    "download_url": ""{XXXX concealment XXXX}"",
                    "status": "completed",
                    "recording_type": "shared_screen_with_speaker_view"
                },
                {
                    "id": "1d86aa0d-fe8e-4707-8194-6cfbef617b63",
                    "meeting_id": ""{XXXX concealment XXXX}"",
                    "recording_start": "2021-07-29T03:25:24Z",
                    "recording_end": "2021-07-29T03:25:35Z",
                    "file_type": "M4A",
                    "file_extension": "M4A",
                    "file_size": 175415,
                    "play_url": "https://us06web.zoom.us/rec/play/h6PVv6FX6ym_Pb3ig7eA2sALVHvyDnCUSj9kmy88g98XjnpPS2k-y639YPsRkZZ2Gzq6VcxwwYy9vgYL.1WqM-WxAv7qPhyCx",
                    "download_url": ""{XXXX concealment XXXX}"",
                    "status": "completed",
                    "recording_type": "audio_only"
                }
            ],
            "password": "{XXXX concealment XXXX}"
        }
    },
    "event_ts": 1627529192712,
    "event": "recording.completed",
    "download_token": "{XXXX concealment XXXX}"
}

Hey @rc-tech,

Thank you for reaching out to the Zoom Developer Forum. This API will only return that array when the Record a separate audio file of each participant setting is enabled. We cover this in the documentation here so I’ll work with our documentation team to update the webhook reference as well.

Thanks,
Max

Thanks for reply, MaxM.
Is this setting just for local recording?

Hey @rc-tech,

This setting would only apply to Cloud Recordings. Local Recordings aren’t accessible via API.

Thanks,
Max

Thanks again, Maxm

Local Recordings aren’t accessible via API.

yes. I can see but I could not find the setting for Cloud Recordings.
I just found this document but it seems to be written for local recordings.

If I’m wrong, it’s good.

Could you tell me where can I find the configuration ?

Maybe is this setting not available in Japan?

Hey @rc-tech,

In order to enable Cloud Recording please make sure that you have a Pro Plan or higher and that you meet the following prerequisites:

image

Let me know if that helps.

Thanks,
Max

We’ are using Pro Plan.

Besides, Cloud Recording is enabled but I cannot find Record a separate audio file of each participant setting.

Could you share screenshot of the setting to show where it is ?

Hey @rc-tech,

That’s a good point! I see what you were saying. Whereas this is typically enabled via the Client, I’m not seeing a setting for Cloud Recording. I’ll check with my team and see if I can get clarification around this.

Thanks,
Max

Thanks MaxM.
I can only see Record a separeate audio file of each participant setting here.

But it looks like the setting is for local recording. It’s pro plan account.

I’ll wait for your team’s answer. thanks.

Hey @rc-tech,

My apologies, no answer on this just yet. I’ll get back to you ASAP.

Thanks,
Max

I’m still waiting.
I hope this doc describes about future release.

@rc-tech My apologies for the delay here. I found that this was mistakenly included in our documentation. We’re working with our team to have it removed.

Sorry for the confusion here. Let me know if you have any questions.

Max