How to add / change scopes in an OAuth app I created?

How are you all?

I have an app that I created according to the information provided by

The app is set at the Account Level and works just fine - But I cannot use the connection to get meeting participant reports with this API command - because I’m getting error 404.

As far as I understand I need to have this scope: report:read:admin that I don’t have now in my app - so I want to add it to the scops I added when created the app - but I see no way to edit the app scops…

Is there a way to add / change scopes in the OAuth app I created?
If so - how?



The scope you mentioned is only available for Account Level apps. If you have created a user managed app, you may not be able to see that scope. You will have to create a new app in this case.


As I mentioned The app is set at the Account Level and works just fine.
How can I edit / add another scope?


You can add and remove scopes on the Screen of your app. Here is our support documentation on this topic:

Screen Shot 2022-11-02 at 11.27.42 AM


I don’t have any button to edit / add scopes

@RamF ,

It looks like you may not be assigned the appropriate developer permission. If you don’t have Developer permissions, contact your account admin to set up Role Permissions. Once applied to your account, you should be able to edit the scopes for the APP.

Set up your Developer account

I’m the account admin and all the role settings are on:

@RamF are you the owner of the app?

Was this ever resolved? I am an admin and one of my developers has a similar issue.

1 Like

Hi, @ranjit.pookkottil,

Thank you for posting in the Zoom Developer Forum – happy to help here. Can you share more detail on the behavior your developer is seeing? If you can provide a screenshot, that will be helpful in diagnosing what may be going on.