How to add invitees when creating meeting via API

What is the proper way for attaching the invitee(s) to a meeting when created via the API?

You documentation (https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingcreate) states there is a settings parameter to add “meeting_invitees” which should be an array object of emails inside the settings parameter, i am getting back error with this payload:

{
  "topic": "test meeting",
  "type": "2",
  "start_time": "2022-02-01T19:00:00+00:00",
  "duration": "30",
  "timezone": "UTC",
  "password": "string1",
  "agenda": "This is the agenda text",
  "settings": {
    "meeting_invitees": [
      "persona@email.com"
    ],
    "alternative_hosts": "alt@host.com",
    "alternative_hosts_email_notification": "false",
    "registrants_email_notification": "true",
    "registrants_confirmation_email": "true"
  }
}

Error:

<error>
    <code>300</code>
    <message>Request Body should be a valid JSON object.</message>
</error>

Hi @bk-zoom ,

I was able to reproduce this error as well. I’ve opened up an inquiry with our API engineers (ZOOM-338682). I’ll keep you updated!

Gianni

@bk-zoom hello this is my fault, it should be an array of objects like this:

“settings”: {
“meeting_invitees”: [
{“email”: “persona@email.com”}, {“email”: “persona2@email.com”}
],

Hi Gianni,

When the meeting is created, is it supposed to send an invitation email to all the given invitees? Because in my case, it does not.

Do I miss something?

Btw, here is how I create my payload:

const invitees = (this.meetingFormGroup.getRawValue().invitees as string)?.split(';').map(i => ({ email: i })) || [];

const meetingPayload: Partial<MeetingPayload> = {
  topic: this.meetingFormGroup.getRawValue().topic,
  agenda: this.meetingFormGroup.getRawValue().agenda,
  type: MeetingType.RECURRING_NO_FIXED_TIME,
  duration,
  password: '', // will be set automatically by zoom API
  timezone: 'Europe/Paris',
  settings: {
    meeting_invitees: invitees,
    registrants_email_notification: true,
    registrants_confirmation_email: true,
  }
};

Joachim

Hi @jl-zoom ,

Check your email settings on your account for meetings. See if the box is checked. The API request with

registrants_email_notification: true,
registrants_confirmation_email: true,

Should be sufficient in enforcing this setting, but let me know what you see in your portal.