How to allowed registered participant to meeting

We are creating zoom meeting using zoom api. And Attendee register to that meeting and there register request is approved by us to join meeting using unique url for this registrant.
When they try to join meeting using unique url , their meeting join request come under waiting room until and unless host can’t add them they can’t join meeting.

How such attendee can bypass from waiting room and directly join meeting?

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?
For meeting creation : Post # /users/{userId}/meetings
For add meeting registrant : post # /meetings/{meetingId}/registrants

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Create meeting using api with waiting_room set false.
  2. add meeting registrant for created meeting
  3. Open attendee Join url what received after approval request for this meeting.
  4. When its opened attendee getting Message "Please Wait, the meeting host will let you in soon " until and unless meeting host not add from waiting room the attendee can’t join meeting even though that attendee already registered for this meeting.

Guide us how to bypass waiting room for added attendee.

Hi @avinash.moharil – thank you for your question. You can review the settings to disable the meeting waiting room here.

Let me know if this solves your goal.


I have integrated web client sdk in my platform. At first, I can join the zoom webinar as an attendee from my platform itself and promote myself as a panelist from the zoom web app but after I leave the webinar from my platform and join again I am getting an error message “Your connection has timed out and you cannot join the meeting. Verify your network connectivity and try again.”

In the console, I am getting the message “{method: “join”, status: false, result: “Please enter TK parameter to join as a panelist.”, errorMessage: undefined, errorCode: 1}”

I am using “@zoomus/websdk”: “^1.9.1”

Please let me know how can I solve this issue.

Hello Gianni,

Our goal is not resolved. Checked Step what I did :

  1. At out zoom account level set waiting room disabled.
  2. Created meeting using zoom api :
    -While creating meeting waiting_room =false, approval_type=1 and registration_type=1 mean attendee need to register first and host will give approval on their registration request and providing joining URL to attendee.
  3. From our portal attendee registered to that created meeting and their registration request approved from us and assign them generated unique join_url.

When attendee joined with their unique join_url then their joining meeting request come under waiting room.

Kindly guide us seamless way so that our registered and approved attendee join meeting directly without putting under waiting room.

Nitin Chopkar

1 Like

Hi @jajeefoundations21 – are you working on this with @avinash.moharil? Do you have a string set for password if waiting_room is set to false? In order to fully disable waiting_room, you have to have a password for security reasons.

Please confirm with me if this is the case and then we shall troubleshoot further if not.


Hi @ashishxporium – I have seen this error before in the following circumstances:

  1. You are not using a JWT App type for the key and secret.
  2. You are not using a Pro or higher Zoom account .
  3. You are not using a real, running meeting / webinar id.
  4. There is an issue with your signature generation .

Does any of the above hold true for you? If after this you’re still experiencing this issue please email your meeting ID and Web SDK signature to with the error and a description of the issue and we will investigate further.

Thank you,

Hello Gianni,

Yes we are working same jajeefoundations21 too.

I don’t know about string set for password. Please guide us how to do string set for password.

Nitin Chopkar

Hi @jajeefoundations21! In order to set a string, you just come up with a unique password in the form of a string according to the requirements shown below :grinning_face_with_smiling_eyes:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.