How to call MyMeetingActivity after inherting SDK's MeetingActivity

I Need to disable Screenshot/ScreenRecording while in a meeting. I’ve followed the steps which were mentioned here - How to disable screen recorder and screen shoret in zoom sdk

I’m calling the activity as shown in below image. But as soon as this method is getting called, app is just displaying blank screen and restarting. Is there problem with calling the activity? and also there are no logs which relate to this issue. MyMeetingActivity(WorkPls) is getting created and later whole app is restarting.

The code in the MyMeetingActivity(WorkPls) is same as in the given demo app MyMeetingActivity

P.S - I don’t want to have CustomUI for Zoom Meeting. I just need Default UI with disabling Screenshot and Recording

Hi @suhassrikar77, thanks for the post.

I’m not sure what the WorkPls Activity in your app is doing, but there are two main actions required in order to extend the MeetingActivity class:

  1. Define an Activity in your app which extends MeetingActivity
  2. Define a string resource in your config.xml with a name attribute of zm_config_conf_activity and a value containing your Activity class’s package + name (so if your package was and your Activity was MyMeetingActivity, it would be


Hi @jon.lieblich , WorkPls is my MyMeetingActivity it has the same code present in the us.zoom.sdkexample2.MyMeetingActivity

Now my requirement is that I don’t need custom UI. I just want to disable the screenshot and recording in the default UI. Is there anyway where I can have default UI while inherting the SDK’s MeetingActivity?

Hi @suhassrikar77,

Yes, the approach mentioned in my previous reply is how you would do this. This will allow you to extend the MeetingActivity class, which hosts the default meeting UI. By naming your Activity in your config.xml, you are telling the SDK to use your own instance of MeetingActivity, rather than the one defined in the SDK.


1 Like

Thanks for the help @jon.lieblich . I got it figured to disable screenshot with default UI

Hey @suhassrikar77,

Awesome! We are happy to hear :slight_smile:
Please let us know if you run into anything else.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.