How to setting for API user background blurring


I am trying to Zoom’s background blurring using the [Reference URL], but it is not working.

The method and argument to use seems to be setVirtualBackground({id:‘blur’}), but I couldn’t figure out when to use it.

[Reference URL]

Why doesn’t the “blur” appear in the settings window?

[meeting start method at Meeting SDK (use React)]

success: () => {
success: () => {
ZoomMtg.setVirtualBackground({id:‘blur’}) // is it correct ?
error: () => {

[user setting by meeting API]

“virtual_background”: true,
“virtual_background_settings”: {
“enable”: true,
“allow_videos”: true,
“allow_upload_custom”: true,
“files”: [
“name”: “San Francisco”,
“type”: “image”,
“is_default”: true


  • Device: macbook M2
  • OS: macOS 13, or 14
  • Browser: Chrome

Hi @developer_mstage
Unfortunately, there is no way to set a users background to Blur via API

thank you for your reply, Elisa.

Is there a way to provide “blur” settings to participants other than through the API?

I’m using an ISV Partner Program account.
For example, I would be very happy if I could create a dummy API user that could change settings and set “blur” from the management GUI.

Hey @developer_mstage
Sorry for the late reply here!
As I mentioned this feature is not available the only way to blur a user background is during the meeting or changing the users settings > Background effects via the client

1 Like

Hello @elisa.zoom .

I understand from your explanation. I look forward to updates to the API functionality. :cry:

Thank you, for your support.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.