I cannot create a publishable URL

I want to create a “Publishable URL”, but in order to do that, it tells me:
“You are missing the following information: Redirect URL for OAuth (Production)”
But I already entered the redirect URL.
It also tells me “To use production credentials without publishing your app, please generate a Publishable URL”, which I cannot do, as stated above.

The forum didn’t let me add two screenshots, so I awkwardly had to make a screenshot of the screenshots - sorry about that:

Hey @mo11,

Thanks for reaching out about! Happy to help.

To that end, I believe the reason you’re not seeing the redirect url (production option) is because your app is likely set to “intend to publish: no”. When this is the case, you will only have 1 redirect URL option.

To submit a request for a Publishable URL, we require you to confirm that you have the intention of publishing your app at some point in the future (Publishable URLs are intended for dev/beta testing prior to this).

To resolve this, you can go to the Activation tab of your app and click Change Now to switch the app intention to “yes”:
image

After you do this, you’ll see the following blue link appear under your Publishable URL on the same tab:

The Redirect URL for production will also appear on the App’s Credential tab—fill this out and then proceed to request a Publishable URL using the blue link referenced above.

I hope this helps to clarify!

Best,
Will