Invalid Redirect(4700) Error when OAuth flow (despite whitelisting)

Description
Invalid Redirect Error when OAuth flow

Error

Invalid redirect: https://www.meetus.jp (4,700)

Which App?
MEETUS

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Access with below like url
    https://zoom.us/oauth/authorize?response_type=code&client_id=XXXXXXXXXXXXXXXXX&redirect_uri=https://www.meetus.jp
  2. Sign in valid account
  3. See error

Additional context
It was working fine for 2 years,
After that no change, but 3 hours ago it suddenly stopped working.

Same issue here, with our development environment credentials.
A whitelisted URL is not accepted and we get an Invalid redirect error.

AppId: 6LPtCfIDTb2_Uxg6KZ5kTg

Hello @taro Thank you for this,taking a look at it should have an update shortly.

Regards, Kwaku

Look at it for you too @jenniferb

Regards, Kwaku

Hello @jenniferb can you confirm the App ID not seeing anything under the one provided or if you could give me the name of the App

Regards, Kwaku

Hello @taro it looks like there is a problem with the url, its not working on and I think that is the reason the redirect is not working this is what happens when I navigate to the page provided as the production redirect. Please fix the issues with the page and I am sure that will resolve the redirect, if it doesn’t please let me know here.

Hello @kwaku.nyante.

Thank you for confirmation.
But I’m sorry. The server with that URL was down for maintenance at midnight in Japan time.
It’s working now.
And the problem keeps reproducing.

And “Redirect URL for OAuth” and “Add allow lists” match.

https://www.orthos-demo.com” is probably for development and may not be needed now.

@kwaku.nyante Name of the app is Marvelous.

Hello @taro from our records it looks like https://www.meetus.jp was removed from the whitelist on May 11th. So we can we try removing the url from the allow list and submit an UPDATE request I will approve it then right after that submit the UPDATE request and add the domain to the allow list and i will approve it and lets see if that resolves the issue. Unfortunately any change in Production related environments will require approval of an UPDATE request.

Regards, Kwaku

1 Like

Hello @taro just approved it please submit the next request.

Regards, Kwaku

I just submitted the next request. thank you.

thank you. I was able to get the authorization code at https://www.meetus.jp/.
but very sorry.
There was a mistake in the allow list setting. I added the following URL (https://www.meetus.jp),I didn’t need the trailing slash.
so could you please approve it again?

Hello @taro sorry I was offline since our team does not work on weekends, Its been approved now and seems to be working as expected now.

Regards, Kwaku

I was able to get the authorization code from https://www.meetus.jp.

Thank you very much for helping me.
Thank you and your team.

Hello @jenniferb can you confirm the issue is still not working. I just tried it using my test account for these situations and it does work. Please be aware the dev redirect url can only be accessed by zoom users on the same account any external zoom accounts will receive an error.

Regards, Kwaku

Hi @kwaku.nyante,

unfortunately, we still get the same error:
Invalid redirect: https://beta.heymarvelous.com/settings/integrations/zoom (4,700)

And we are aware of the same account limitation.
This used to work when we initially developed the app.