Invalid signature err

The previous week i was using my zoom sdk app normally without having any bugs and without having any issues now it says to me

  1. errorCode: 3712
  2. errorMessage: “Signature is invalid.”
  3. method: “join”
  4. result: “Invalid signature.”
  5. status: false
    version: 2.6.0
    i have checked credintials so many times this is my signature
    eyJhbGciO[REDACTED]UsIv3-4RkO-0lQ
{
  "alg":"HS256",
  "typ":"JWT"
}
{
  "sdkKey":   "37Hm4tqH3hivbcic7trVNwgqhSGe....",
  "mn":       "8703113....",
  "role":     1,
  "iat":      1662728120,   // Friday, 9 September 2022 12:55:20
  "exp":      1662735320,   // Friday, 9 September 2022 14:55:20
  "appKey":   "37Hm4tqH3hivbcic7trVNwgqhSGe....",
  "tokenExp": 1662735320    // Friday, 9 September 2022 14:55:20
}

your token looks good

update to 2.7.0, create a new simple test meeting

  • Registration NOT required
  • a simple Passcode
  • no waiting room
  • Options: Allow participants to join anytime

enter meeting with “role = 0” (as attendee)

what happens?

Jürgen

@j.schoenemeyer thanks for helping @elmolcenter with this! We are not supposed to share tokens on the forum so I’m redacting that info.

still the same bug nothing still tilling me signature is invalid

then you have to check if your sdk app (or your zoom account) is broken

I would check it with the example app on github (-> CDN version)

If you get the same error, recreate the Meeting SDK app

if this don’t help create a new free zoom account, create a Meeting SDK app and test
(hint: you can use this app to get token for your original account meeting - tested with “role=0”)

Hi @elmolcenter,

Were you able to get the same error with using the Web SDK sample app from github?