Is the page_size option not functional?

No matter which integer I declare for the page_size option in my API call, the default value of 30 is returned.

Options used:

headers: {
  authorization: 'Bearer KEY',
  from: yesterdaystart,
  to: yesterdayend,
  page_size: 150,
  type: 'live',
}

Whether I use 1 or 300 I get the same page size returned of 30 results, is pagination the only way to retrieve datasets larger than 30 results?

Hey @Naji,

Which API are you using? Make sure to pass the page_size as a query param and not a header.

api_url?page_size=10

Thanks,
Tommy

I’m seeing a similar issue with https://marketplace.zoom.us/docs/api-reference/zoom-api/cloud-recording/recordingslist

For example:

I make the call GET https://api.zoom.us/v2/users/<user id>/recordings?from=2020-08-20&page_size=5 and I get a response:

{
    "from": "2020-08-20",
    "meetings": [...],
     "next_page_token": "MOz7cn6yEivra7B6y5HNXu8AxL4pYFrwHx2",
    "page_count": 9,
    "page_size": 5,
    "to": "2020-09-03",
    "total_records": 44
}

where meetings is a list with 44 items, regardless of what I pass in as page_size or when I try using next_page_token.

Hi @ryan,

Can you confirm that within the meetings object in your response that there are more than 30 individual records showing in the first page of results? I should clarify that the “total_records” number of 44 refers to records included in subsequent pages as well (even though you won’t see them all in the first page, necessarily).

If you have a copy of the full request and payload response, I’m happy to take a closer look as well!

Thanks,
Will

Yes, thats the issue I’m seeing, instead of just 5 records (per page_size=5), I get all 44. Do you want me to email or dm the full payload?

Hey @ryan,

Thanks for clarifying—yes, if you could email the full payload to developersupport@zoom.us and reference this thread, this will let us take a closer look.

Thanks!
Will

ok, I sent the email!

@ryan, thanks! I just connected with you there.

This issue is being looked into by our Engineering team. I’ll update you as soon as I hear back on this. (ZOOM-194965)

Best,
Will

Very late update but query parameter rather than the header worked for me, so:

https://api.zoom.us/v2/metrics/meetings?page_size=300&fro...

Then pagination for when results break 300

Thanks!

@Naji Thanks for the update — I’m glad you figured it out!

Best,
Will