Issue | Participants Name in Cloud Recordings not visible | Zoom Web SDK

Description
We have implemented zoom as a video-service in our organization (SHL). We have encountered an issue where Participant names are not visible in cloud recordings after grid view has been launched. Please let me know how we can enable this?

Error
No Error, just participant name is not coming.

Which Client Web SDK version?
1.8.6

To Reproduce(If applicable)

  1. recording url :- [REDACTED]

Screenshots

Device (please complete the following information):

  • Device: Lenovo Desktop
  • OS: Windows 10
  • Browser: Chrome
  • Browser Version 89.0.4389.9

Additional context
Add any other context about the problem here.

Hi @vipin.kaushik,

Thank you for providing that information. I see you are testing on Client Web SDK 1.8.6. Can you test with WebSDK version 1.9.1 ?

If you still are experiencing the same issue, let me know and we’ll take a closer look.

Best,
Donte

Thanks, I will test and let you know. We are planning to upgrade to latest version and enable grid-view feature also. Will let you know if it gets fixed with latest version.

Hi @donte.S , I created a meeting and launch the same with zoom/websdk version 1.9.1
But when I downloaded the cloud recording , still no label for participants name is visible in the recording.

Meeting Id :- [REDACTED]
zoom download url: [REDACTED]

Request you to have a closer and let us know what could be the reason.

Hi @vipin.kaushik,

Are you seeing that participants names are not being shown with the Web SDK only ? Or are you also seeing this occur with the Web client and Zoom app as well?

Thanks,
Donte

Dear @donte.S I have only tried by creating a meeting using my SHL JWT app’s api key and secret and then utilizing the same on client side with zoom web sdk. I can try with Web client and Zoom app as well and will let you know what I get. But I think I require this when I am creating meetings using zoom api and utilizing the same in my app using web sdk.

Hi @vipin.kaushik,

Thanks for clarifying, I tested out the issue on my end and I am able to see the name of the participant even when switching to gallery view. I think the key here is that the right setting has to be enabled, please make sure you have the ‘Display participants’ names in the recording’ setting enabled. This setting can be found in your Zoom web portal settings on the recording tab. Please see screenshot below.

Screen Shot 2021-03-25 at 5.07.27 PM

If this does not help, here are the steps I used when testing this issue,

  1. Host a meeting from the Web SDK
  2. Record the meeting
  3. As the host, switch to gallery view
  4. Stop the recording
  5. End the meeting
  6. Observe the recording

Please let me know if you are doing something different.

Best,
Donte

Dear @donte.S , Thanks a lot for detailed explanation. We are very close to resolve this query. What I have figured out, the issue is with Users created using cust_create option using API.

The accounts we create dynamically as per the requirement , create video-sessions against them. These accounts cant be logged into the portal and do the required settings.
I am trying to analyze the Users APIs to update the settings but could not find any flag for 'Display Participants on cloud recordings".
Please see if you can help to figure out how I can enable this setting using API instead of going to portal.

Thanks a lot !

Hey @vipin.kaushik,

Thank you for providing more detail! Currently, we don’t have an API feature to set the Display participants’ names in the recording setting. If you would like this feature to be considered for a future release, I recommend posting in the #feature-requests category.

In the meantime, you can try to enable this setting at the account level to set it for API users. Let me know if that works for you.

Thanks,
Max

Hi @MaxM I have raised the request for the same .

This is critical for us. Also suggested the alternative to drive this settings at least from Admin user. If the flag is enabled for Admin account then this must be on any member/licensed account by default.

At, SHL (https://www.shl.com/) we need to have 200 to 500 licensed accounts at a time to host multiple Live Video Interviews. We can not ask each and every employee of our organization to sign up for Zoom member account and provide their host_id something. So we create users on fly using cust_create option.
I got checked that in our case for Admin the feature is on but for API users its not.
But if you are suggesting that there is some other place on Admin account where we can set default settings for API users at once for all, please share the steps. Actually I dont have direct access to Admin account in my organization but I can check with the guy having that.
Thanks a lot for being so active on my query. I appreciate that.

Hey @vipin.kaushik,

Thank you for providing more detail on your use case. I understand how this is an important feature for your team so let’s see if we can find a workaround. As a test, please try the following:

  1. Navigate to Account Settings > Recording
  2. Confirm Display participants’ names in the recording is enabled
  3. Lock the Cloud Recording section for all users

  1. Create a new custCreate user
  2. Test if that fixes the issues with recordings

Let me know if that helps.

Thanks,
Max

Dear @MaxM I checked with the guy having zoom admin access , but could not find any specific option for 3rd point Lock the Cloud Recording section for all users. Please see if you can share some screenshot for this also. Meanwhile I will try to schedule meetings with new users and will let you know if it solved the issue.

Thanks

Hey @vipin.kaushik ,

The lock option is in the top right, which enforces the admin level recording settings for all users on your account.

Thanks,
Tommy

Thanks @tommy I have shared the screenshot with the Admin guy, will update as soon I get some confirmation and participants name in our recording

@tommy I got the settings said above , we are in process of creating zoom sub accounts and then will that locking for particular sub account.
Thanks for this ,just would you please can confirm one more thing, how can we get the same meeting id on create, if for some meeting id already created at zoom end for same request. Means can we pass some unique parameter to zoom in create-meeting api request for which we will get already existing meeting id instead of getting created a new one every time.
I got to know about personal meeting id, can I change or define the same everytime while creating the meeting using create-meeting api ?

Hey @vipin.kaushik,

Thank you for your updates, let us know if you have any questions as you create new accounts.

If you want to schedule a meeting using the same meeting ID each time, I recommend using, as you mentioned, the Personal Meeting ID (PMI).

When using the Create a Meeting API, you can set the settings.use_pmi property to true in order to create a meeting using the PMI:

image

Let me know if that answers your question.

Thanks,
Max

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.