Issues with joining meetings, losing mic and/or freezing video after joining

Our organization, IMACS (Institute for Mathematics & Computer Science), teaches weekly online mathe enrichment lessons to children in grades K-8. We started using embedded Zoom within an IFRAME this past March and ran into technical issues. Over the last six months we’ve been working with our Zoom rep and one of the developers but so far nobody has been able to resolve the following issues:

  1. Some students aren’t able to join our embedded Zoom meetings.
  2. Some students join fine, but then their mic isn’t working which is sometimes resolved by leaving and rejoining the meeting. Other times their mic works for a while and then just stops working.
  3. Some students join the meeting by only see a blank screen.
  4. Some students experience sluggish audio and often video freezes.

These problems occur with about 10% of our students. We can’t determine any pattern to why this subset of students experience issues as described above.

The Zoom people suggested that I post the details from a test meeting we held yesterday along with the log we captured and the code that we developed to embed Zoom in an IFRAME. We hope that someone else has experienced similar issues and may have some suggestions. It’s a stressful situation teaching young students when the technology has glitches.

We are using Meeting SDK v2.15.2 with a client view in an IFRAME.

The following are notes from our developer who did the testing yesterday followed by the logs created in this meeting and a link to the code we developed to use embedded Zoom with our students:

"Embedded zoom worked on my laptop just fine for 20 minutes. Then suddenly my microphone stopped working. I switched to a different mic, then switched back and it worked again. A few minutes later, I froze and my video stopped working. I left and came back in and my video didn’t work at all. The Start/Stop video button doesn’t work at all. If I turn my video on, I can click to start the video but nothing happens. I also tried a screen share and that didn’t work for a good 20 seconds or so. It then appeared fine and I was able to start and stop shares and it seemed to work okay. I opened the console and I’m getting never ending errors like the ones below. They just keep repeating in that pattern. "

Link to code our team developed for embedding Zoom into an IFRAME:

We are hopeful that someone in this forum can assist us.

Terry Kaufman

1 Like

Hi @terry.m.kaufman
Thanks for reaching out to the Zoom Developer forum and welcome to our community, I am happy to help here!
Sorry for the late reply here!
We have created an internal ticket with our Support team for you and they should be communicating with you briefly.