Jbh_time setting issue

Description
Hello. I’m using the API with curl in PHP. Everything is ok but the jbh_time setting. I set join_before_meeting to true but I can’t set to “5” the jbh_time.

Error
No error

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

How To Reproduce (If applicable)
Do an update API request with {
“settings”:
{
“join_before_host”: “true”,
“jbh_time”: “5”
}
}

This is the same issue when I create the meeting

Hi @acpc49,

Thanks for reaching out about this, and happy to help.

Can you please ensure that you’re passing 5 as an integer in your request body instead of a string?:
image

Let me know if you still have issues after making this adjustment.

Thanks!
Will

Hello.
I tried both of these ways, none working

{
“settings”:
{
“join_before_host”: “true”,
“jbh_time”: 5
}
}
or this
{
“settings”:
{
“join_before_host”: “true”,
“jbh_time”: “5”
}
}

Hi @acpc49,

Thanks for giving this a try. Can you please share these request details and your account ID or email address associated with your account with me at developersupport@zoom.us and reference this thread?

This will help me to take a closer look.

Thanks!
Will

I’ve noticed the same thing. I’m creating a meeting against my own Zoom account. The account setting for join before host set to false, and I’m able to create a meeting using the API while passing in “join_before_host”: true, “jbh_time”:5, but the API response has join_before_host: true and jbh_time: 0.

Hi @wislon,

Thanks for reaching out about this. Can you share the full API request body and response, as well as the Meeting ID for which you’re not seeing this reflected as expected?

I’m happy to take a closer look.

Thanks!
Will

Done. Sent to developersupport@zoom.us

Thanks, @wislon! I’ve connected with you there.

Best,
Will