Jbh_time still be 0 min although I change it to 10

Description
I try to create meeting with zoom api POST https://api.zoom.us/v2/users/{userId}/meetings

Request

{
  "topic": "test",
  "type": 2,
  "start_time": "2021-09-01T12:00:00Z",
  "duration": 20,
  "password": "test",
  "settings": {
    "host_video": false,
    "participant_video": false,
    "join_before_host": true,
    "jbh_time": 10,
    "mute_upon_entry": true,
    "use_pmi": false,
    "approval_type": 2,
    "audio": "both",
    "auto_recording": "none"
  }
}

But response has jbh_time = 0

Error
jbh_time from response doesn’t equal jbh_time from request

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

Which Endpoint/s?
Create a meeting - Meetings - Zoom API - API Reference - Zoom Developer - Technical Documentation and Reference

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Send request with body in the description
  2. Check jbh_time in response

Hi @thitiphan,

When you make a request to our Create Meeting API endpoint, it will reference your user settings and sometimes these can override the content of your request. In order to avoid this, you’ll need to ensure you have the following setting checked off and set as “anytime”:


Once you make this change, you should see the jbh_time reflected in the API response correctly.

Let me know if this helps, or if you continue to not see it reflected as expected!

Will

1 Like