Join Audio By Computer Pop Up Not Coming ( Thats why no sound ) When Screen Already Shared on Webinar


We’re using web sdk 2.9.7 and we make only WEBINARS.

As you know, user has to click “join audio by computer” to listen webinar.

If host/admin just sharing camera, then new attendes can see “join audio” pop up and click it. They can hear and it works.

If host/admin share screen with camera, then new attendees can not see join audio pop up and can not hear ( no sound )

Sharing screen remove join audio pop up and attendees can not hear.

If we stop sharing screen and ask user to refresh then pop up comes and they can hear.

Tested on chrome last versions.

It’s a bug. Sharing screen removes or stop join audio pop up on WEBINARS.

Hi @hasanali ,

Have you tried replicating this issue on the latest web sdk 2.10.1?

Hi @chunsiong.zoom we will replace and let you know. Thank you

We tried the new SDK but nothing changed. Please try it like this;

1- Open a webinar
2- Share a screen with your camera
3- Join as attendee
4- There will be no “Join Audio” pop up and that’s why no sound.

If you do not share screen, there is no problem.

Thank you

@hasanali I’ve just tried on my machine, and I’m unable to replicate the issue.

The popup does show up, look at the attached screen capture

are you using client view or component view @hasanali ?

Hi Chun Siong,

First of all, thank you for your time.

Normally you do not need to click headphone. It comes automatically. At the example, you’re clicking it.

For example; test it only camera without sharing screen. You will see “join audio by computer” pop up comes automatically. If you share screen, this pop up does not show up. You have to click headphone icon for sound.

This is not like this on older versions.

we’re using client view.

at your test, join audio pop not coming automatically? Am i right? Normally it comes automatically.

Yes @hasanali , when there is a screenshare ongoing, the audio popup does not happen automatically.

Thank you so much for your response.
So, is it a bug or normal behaviour? This is not like this on older versions.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.