Joining meeting timeout

Hey @r.abdelhamed,

Please private message me your signature and I will debug.

Also see this thread:

Thanks,
Tommy

Dears,

Thanks alot

I issue is solved. I used the your
signature example App and it work with me

1 Like

Happy to hear you got it working! :slight_smile:

-Tommy

How exactly did you get it working? I’ve just installed the latest
git@github.com:zoom/sample-app-web.git, replaced the api token and secret with my credentials and am seeing the “Joining meeting timeout” message.

Did you implement your own signature creation function with the “signature example App”?

Presumably the existing sample app should work as is (given that it is an example of how to integrate with Zoom)

Hi Russ,

There is an issue with Free/Basic accounts being able to join meetings via the WebSDK. A workaround would be to upgrade your account to a Pro Account to avoid.
Let us know if this works for you.

Thanks

Hi @russ

Yes I work with free/basic zoom account
and yes, it works by implementing my own signature using the “signature example App” from my backend code to generate the signature with every meeting id

the existing SDK sample app work but the signature which generates by it has a different time zone than my time check this ticket “Join meeting timeout or signature expired

1 Like

Ah, I’ll take your word for it (I don’t really want to sign up for Pro just to test a bug)

Assuming that would resolve it, might be an idea to show that in the error message too (rather than a timeout)

Thanks for responding!

Hey @russ,

You can also request a free trial here: isv@zoom.us.

We are working on improving the error messages. :slight_smile:

Thanks,
Tommy

hi there I have exact problem and I can’t find a solution for fix it. It was works like a spaceship and now I get this timeout error. I didn’t change anything and I don’t know how to change signature or even I don’t know where I should look… please help me I am on the egde:(

Hi there,

could you please confirm webSDK is not working if the meeting is created by a free account ?
i’m trying it and get this “join timeout” everytime.

regards

Hi @serdarkaksi

What account type do you have Free or Pro? Are you using you PMI or newly generating meetings?

@VincentV Please upgrade to a Pro account. We’re having issues with Free accounts using the WebSDK?

1 Like

Thanks Michael, but I don’t want to pay for a pro account to developp a website for one of my client.
I will check with my client if they can share their pro account.

regards

I upgrade my account to pro version with montly payment 15$ I hope this will fix my problem otherwise I have to demand refund.

I have the same problem over here. It started when it was here (Germany) just past midnight and the meeting i was trying to connect to was hosted in Canada, which is 6 h behind. So i was at a different day than the hosted meeting. Before midnight everything just worked fine. We suspect that might have caused a problem. Right now its here and there the same day (here 1PM, over there 7am) and i’m connected without an issue. Might be worth to have a look.

Hi there

I got this error if I init webSDK with the same email address (userEmail) that my zoom account email address. It makes sense.
Using any other userEmail it works as expected.

Hi
can someone give me example of the javascript code used ?

I now have a pro account, but still have timeout when trying to joing a meeting with a non-registered user using webSDK

No more information, juste time out joining session

Is there a way to test the signature to see if it’s valid ?

regards

it’s not working even using the sample provided in github (with API key and secret put in the JS directly for tests), nor my personnal development.
same error on both

should I also send a ticket to support as i now have pro account ? we have a big meeting in 2 weeks and need webSDK to work

i’m base in Paris, France, using the timezone of Paris for both creating the meeting and generating the signature, if this may help.

regards

problem solved, I used the API_KEY in account settings, but finaly, creating a develop JWT app gave me other API_KEY/Secret _key and this one is working.

Well this is a new pro account just created so I’m sure i didn’t had any

you can just go to marketplace.zoom.us, sign in and then click manage on the top to get all the existing app
select the corresponding APP, and click on APP credentials, you will see your current key, you can also generate there a new secret key if needed

or when you choose “Build app” in the develop menu, you directly have the “view here” link