V1.7.4 Your connection has timed out and you cannot join the meeting. Verify your network connectivity and try again

Hi @tommy,

Description
Updated to the latest web SDK 1.7.4 but still getting this error.

Error
Your connection has timed out and you cannot join the meeting. Verify your network connectivity and try again.

Which version?
1.7.4

Screenshots

First, i have the error “The service is temporary”, now i have this error "Your connection has timed out and you cannot join the meeting. Verify your network connectivity try again

Hi @dmunozduarte,
Can you test your meetings again? This time if the 403 request error shows up, click retry to see if you can join the meeting. This is a workaround until we deploy a new version of WebSDK in the coming days.

I can’t join the meeting. Still the same error

What is the meeting ID? Could you try to join using this meeting ID. - 282087379

I tried with that meeting id. and i give error “Join to fail”

I have the same issue, does anyone could help me, below my code

(function () {

import { ZoomMtg } from '@zoomus/websdk';

console.log('checkSystemRequirements');
console.log(JSON.stringify(ZoomMtg.checkSystemRequirements()));

ZoomMtg.preLoadWasm();
ZoomMtg.prepareJssdk();

//ZoomMtg.setZoomJSLib('http://https://localhost:9999/wwwroot/sample-app-web/Local/node_modules/@zoomus/websdk/dist/lib/', '/av');
ZoomMtg.setZoomJSLib('https://source.zoom.us/1.7.4/lib', '/av');

var API_KEY = '############';    
var API_SECRET = '################';


document.getElementById('join_meeting').addEventListener('click', function (e) {
    e.preventDefault();

    if (!this.form.checkValidity()) {
        alert("Enter Name and Meeting Number");
        return false;
    }

    var meetConfig = {
        apiKey: API_KEY,
        apiSecret: API_SECRET,
        meetingNumber: parseInt(document.getElementById('meeting_number').value),
        userName: document.getElementById('display_name').value,
        passWord: "##################",
        //leaveUrl: "https://us04web.zoom.us/j/795691992?pwd=UkJqQnhVenZ5dlRPL3VKeHRUYVlLZz09",
        leaveUrl: "https://us04web.zoom.us/j/7956919929",
        role: 0
    };


    var signature = ZoomMtg.generateSignature({
        meetingNumber: meetConfig.meetingNumber,
        apiKey: meetConfig.apiKey,
        apiSecret: meetConfig.apiSecret,
        role: meetConfig.role,
        success: function (res) {
            console.log('signature: ' + res.result);
        }
    });


    ZoomMtg.init({
        leaveUrl: meetConfig.leaveUrl,
        isSupportAV: true,
        success: (success) => {
            console.log(success)

            ZoomMtg.join({
                signature: signature,
                meetingNumber: meetConfig.meetingNumber,
                userName: meetConfig.userName,
                apiKey: meetConfig.apiKey,
                userEmail: 'asdf@.com',
                password: meetConfig.passWord,
                success: (success) => {
                    $('#nav-tool').hide();
                    console.log('join meeting success');
                },
                error: (error) => {
                    console.log(error)
                }
            })

        },
        error: (error) => {
            console.log(error)
        }
    })

});

})();

@financeiro Could you DM me your API Ley/Secret and Account ID/Number so that I can investigate further?

@dmunozduarte Could you DM me your index.js file and API Key/Secret along with Account Number as well?

Thanks

Ok, no problem. i sent via DM the js file

I’m having the same issue

I also have the connection timed out error issue. I am using the updated SDK.

RK

@rk1 @kalmuraee @dmunozduarte @financeiro - We’re having some issues with Free accounts and Single Pro License accounts using the WebSDK. We are working on fixing the issue now. I’ll follow up on this thread once the fix is released.

@rk1 @kalmuraee @dmunozduarte @financeiro

A workaround would be to deactivate your Accounts JWT app and reactivate it again. Can you let me know if this works for successfully joining meetings that do not have waiting room feature?

Hi Michael,

Thats right, is working.

thank you

Hello @Michael_Purnell

I’ve tried deactivating and Activating the JWT and SDK, Still it didn’t worked in my case.

@financeiro - Glad that it’s working now.

@kalmuraee Can you DM me your Account ID/# and API Key/Secret?

I found the solution, it is because a previous meeting was not finished

I recommend
https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingstatus
{
“action”: “end”
}

@Michael_Purnell I’m having the same issue as @kalmuraee. In the sample app as well as in mine.


Console says:
{method: “join”, status: false, result: null, errorMessage: undefined, errorCode: 1}
Re-activating JWT token didn’t help

@kalmuraee - I was able to test with your credentials and I was able to join a meeting with meeting ID 282087379. Can you try with this meeting ID?

@gurucan - Did you try to deactivate/reactivate your JWT account to see if that works? Also please try to use the newest version 1.7.5. If that doesen’t still work please DM me your account number and API Key/Secret.

I have been battling this for hours today i thought it was due to the quite rude and unceremonious dumping of 1.7.2 support, but upon updating to the newer npm package (1.7.5), and also having to change the hardcoded css/js library refs in my VUE app (why the sdk needs them is beyond me it should be able to find the library and css itself based on its version) but i digress.

After updating i still had the issue, I eventually I tried starting the meeting and it worked, when i stopped the meeting it failed with the timeout error again.

Found out that even if “Join before host” is enabled, if “waiting room” is enabled then you get an unhelpful “timeout” error if the meeting is not running.

I only just got started with Zoom so maybe that was always the case, but I’m sure I didn’t have a problem before the latest round of updates, If they are supposed to be mutually exclusive then it should not allow it to be created with both enabled.

Edit: I did not regenerate my JWT keys, they seem fine because I use them to access the API for creating the meetings as OAUTH to a .net windows app seems to be incredibly painful.