[JS error] RangeError: offset is out of bounds

While monitoring javascript errors happening on our user’s browser, i noticed the following one: RangeError: offset is out of bounds

It occurs time to time and seems to be related to a retry mechanism.
It happened today for a user, the error has been generated 300 times within 6 seconds, exactly every 20ms. It also happened at different timing for other users, not so many times but still generated every 20ms.

The user did not do anything in particular (from what i could check on our RUM)

As you can see it comes from instructions through one of the opened web sockets.
This is a new generated javascript error that was not happening before switching from 1.8.1 to 1.8.5.

RangeError : offset is out of bounds

Which version?

Device (please complete the following information):

  • Device: Desktop
  • OS: Window 10
  • Browser: Chrome 87.0.4280.141

Additional information:
The user seemed to have many problems when connecting to zoom (and initializing the component @join time, probably due to his network (i did not have time to investigate yet)

Hey @nvivot,

Thank you for bringing this to our attention. I’ve reached out to our engineering team in regard to this matter and will get back to you when I have more information. (CS-2820)


Hey @MaxM, I am experiencing the same error but it occurs consistently when you select “Join Audio” in the bottom left hand corner of the iframe, and then select “Join Audio By Computer”. This then throws the exact same error as OP’s in a loop up until the user clicks mute audio. Video is also not being received by other users in the meeting but does not throw any errors on start and the video pops up in screen as expected.

Screenshot 2021-02-02 at 12.19.16

Currently running 1.8.6 but this was also observed for 1.8.5 on Chrome 87 and Chrome 88. Firefox 84.0.2 does not throw the error but the audio and video issues remain the same. Occurs on Windows 10, Mac OS 10.15.7.
Any updates on this please?

Hey @markjdvs,

Thank you for reaching out to the Zoom Developer Forum. Our engineering team is aware of this issue and is working to determine the cause.

That being said, I’m not seeing this when testing with our Sample Web App so there must be some other factor I’m missing that causes the issue. I just have a couple of questions to help our investigation:

  1. Do you see this issue with all users?
  2. Have you tested with the latest version of the Sample Web App?
  3. Did this issue start a particular version?
  4. Does this happen on the latest version, 1.9.0?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.