Access to old version of Web Video SDK (@zoomus/instantsdk)

Is there any way to download the old version of the web video SDK? I’m referring to the last version of @zoomus/instantsdk, which was 1.03 i think?

it was working fine on my app, but when i updated to the @zoom/videosdk, the app slows down when I call stream.startAudio(). I get thousands of Offset is out of bounds errors until the web app crashes.

At this point, I would like to revert to the old version first while figuring out what’s wrong with the new one.

Hey @stipoy

Thanks for your feedback. Could you provide more information about this error for us to troubleshoot the issue? (Platform, Browser,Version)

Thanks
Vic

Hi Vic,

Platform : Mac High Sierra
SDK : Web Video SDK v1.1.0
Browser : Chrome Version 91.0.4472.114 (Official Build) (x86_64)

Calling startAudio() causes the multiple instances of the following error in console :
js_media.min.js:1 Uncaught RangeError: offset is out of bounds
at Uint8Array.set ()
at e.value (js_media.min.js:1)
at e.value (js_media.min.js:1)
at e.value (js_media.min.js:1)
at js_media.min.js:1
at RTCDataChannel. (js_media.min.js:1)
value @ js_media.min.js:1
value @ js_media.min.js:1
value @ js_media.min.js:1
(anonymous) @ js_media.min.js:1
(anonymous) @ js_media.min.js:1

this goes up to thousands in a few seconds, and slows the app to a crawl.

Sidenote : calling startVideo() also causes multiple errors such as
[.WebGL-0x7f80d9304a00]RENDER WARNING: there is no texture bound to the unit 4,
until it hits
WebGL: too many errors, no more errors will be reported to the console for this context.
but the video actually works fine so we may ignore this one.

we’re rushing to launch our app so we’re hoping to just deploy with old instantsdk if necessary.

Thank you.

One of our testers is having the same problem with 1.1.0.

Also we cannot hear any audio in the app anymore, even though we’re running console statements bracketing the stream.startAudio() and stream.unmuteAudio() calls for each user with no errors thrown. (And everyone has their mics and cameras on, and the participants data indicates all users are unmuted) Video seems to be working, oddly.

What else could we do to troubleshoot? Getting this with a mix of latest Chrome/Firefox, both very recently updated/upgraded.

1 Like

@brianWD any chance you have a copy of the old @zoomus/instantsdk?

Reverting from 1.1.0 to 1.0.3 is not a reasonable solution.

My chrome version is Version 90.0.4430.72 (Official Build) (64-bit) and firefox version is Version 89.0.2 (64-bit)
OS is Ubuntu 18.04.4 LTS 64-bit and Web Video SDK 1.1.0

@mitesh.gandhi are you getting the same error?

Yes, I am getting the same error.

@victor.aprea If this is indeed an issue with the SDK itself, reverting until it is stable seems like a perfectly sound solution. Or is there something I am missing?

@vic.yang hope you can give us an update on this. Or maybe a link to the older version. The older one did not have this error. It’s not on GitHub I guess because it had a different name. Hope it can be uploaded somewhere

i think i found a fix here. calling startAudio() before startVideo() seems to fix the issue.

Hey @stipoy ,

Thanks for sharing the solution you found, however it seems like we need to investigate this issue.

Unfortunately the latest version we have available for you to download via the marketplace and NPM is 1.1.0.

That being said, we did just release 1.1.3 with many improvements: https://marketplace.zoom.us/docs/changelog#publications/video-sdk-web-v1-1-3

Please let us know if you still experience the same issue with version 1.1.3 @mitesh.gandhi , @brianWD .

If you are still experiencing the same issue, please provide your code snippets and steps to reproduce the issue.

-Tommy