JWT Deprecation

How do I tell if the JWT app type deprecation (see https://marketplace.zoom.us/docs/guides/build/jwt-app/jwt-faq/) will affect my code or not?

I am using WebSDK to embed a zoom meeting into my website (see GitHub - zoom/meetingsdk-web-sample: Zoom Meeting SDK Web Sample App using CDN 2.9.0 and in index.js have var SDK_KEY = “####” and var SDK_SECRET = “####”) if any of that helps?

Hi Richar,
Thanks for reaching out to the Zoom Developer forum, I am happy to help here!
You will just have to make sure that you are NOT using the credentials associated with the JWT app type

Instead of that, for the WebSDK you should be using the meeting SDK app type

Hope this helps,

Thank you so much for this Elisa. But how do I tell which credentials I am using? Is it in the .js code or is it something else?

I would not know what credentials you are using or how you implemented our sample app on your end @richard2
Are you the developer in your company?

hello, I need your help! After I tried the meeting SDK, I called to update the sub user interface and reported an error! Prompt {“code”: 124, “message”: “Invalid access token.”}

I am but I implemented it so many years ago and it has been completely stable every since that not entirely sure how I got it to work in the first place! I’ll do some digging and work it out…

So I went in to App Marketplace as shown in the screenshot below

and from there went in to the JWT app credentials and compared the key that is in index.js and it is not that one

and then I went into the Meeting SDK one and the credentials in that page are the same as in index.js

I will check things on 1st June but I have a training session at 10am - if I am affected by the JWT app deprecation in a way that I was not expecting is there any kind of test environment so I can check things prior to 1st June?

If the credentials you are using in your integration are the ones from the meeting SDK app type, you should not have to worry about it.

thank you so much for that and your help on this, appreciate it

1 Like

I had an application with jwt which has been outdated for a few weeks. I updated the app expecting to get an sdkkey but I still get only the secret key and apikey.
Im trying to create a meeting sdk app, after filling in all the fields it asks me to add a public file in the root of my project. In addition to asking me for a long list of technologies, privacy policies, legal notices, uploading images, project architecture diagrams, etc.

I don’t know if all this is necessary to update the websdk version but I still can’t create it to get the credentials and the signature.

Im waiting for fix that. Thanks

Hey @zoom68
This topic has been closed, could you please open a new topic with this issue you are facing?