LTI Pro - Safari Blocking Session Cookie

Description
The update on May 30th to the LTI Pro seems to have causes the session cookie to be blocked by Safari. The result is not being able to authenticate with the Zoom LTI from within our LMS.

Error
LTI Error Message: Sorry, your session expired. Please refresh the page or login again.
Server status: 401, unauthorized
Browser error: Set-cookie was blocked due to user-preferences

Which App?
LTI Pro

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Open Safari with default settings
  2. Open the Zoom LTI activity in Moodle

Screenshots (If applicable)


Additional context
The issue also occurs in the secure Brave browser and probably other browsers that have stricter default cookie policies.

We are experiencing this, as well, since the May 30 LTI Pro release. It is also happening on some iOS devices.
Is there a workaround available until this is resolved?

Thanks for adding to the case.

Our rep sent the issue to a solutions engineer.

Unfortunately, all the workarounds I came up with are on the user end:

  • Use FireFox or Chrome (simple)
  • Accept all cookies for the site in Safari (advanced)
  • Use the meeting links in the calendar (simple, but no recording access)

Setting the LTI to open in a new window will fix the issue.

Looks like the developer of the LTI added error handling for the cookie being blocked and added a link that opens the page in a new window, which resolves it.

2 Likes

Thanks for sharing the solution @Dizolivemint ! :slight_smile:

Tagging you @AVJeff, so you see the answer.

Thanks,
Tommy

The page LTI page opens a new tab when the cookie error happens now. This is a great improvement over having to click the link! Pop-ups need to be enabled, however.

@AVJeff
Welcome @tommy !

@Dizolivemint Hoping you can help me getting in to that setting in LTI that needs to be set for open in a new window. Thanks in advance.

Hi @joy.valenzuela !

I should have clarified that the setting is not in the LTI, but in the user’s browser. At least the user will hopefully see an icon if the pop-up is blocked and click it. Not the best UX.

What version of the LTI are you using? Wondering if this is a problem with LTI 1.1 and not 1.3. I see you are a Staff member. Any issues with updating to LTI 1.3? Wondering if 1.3 has the cookie issue.

Thanks!

Warmly,
Miles

1 Like

Hi!

I’m getting the same issue with LTI Pro 1.1 in Blackboard Learn Ultra LMS. I configured Zoom to open in a new window and the issue persists.

The only way to resolve this issue is opening Zoom in another web browser like Chrome or Firefox.

Is there any hot fix scheduled?

Hi @ccabre12 !

Does the new window/tab not pop up or is there an error on the new window/tab? Also, does the address in the new window/tab start with https://applications.zoom.us? Feel free to add a screenshot.

Warm regards,
Miles

@tommy @joy.valenzuela @ccabre12 setting the LTI to open in the same window will bypass the need for pop-up. Not sure if your LMS support this, but in Moodle, I had to set the preconfigured tool this way. Setting an instance does not work: https://tracker.moodle.org/browse/MDL-42067

1 Like

Thanks for the additional info @Dizolivemint ! :slight_smile:

@ccabre12, are you still experiencing an issue?

Thanks,
Tommy

Hi,

We’ve had a few users experience this issue too. A coworker and I did a test run but found that a different error came up. You’ll see it in the image below. He’s using MacOS Big Sur version 11.4. We don’t know what LTI version number we’re using. We’re using Zoom through Canvas.

We did find that opening the link in a new tab worked, but is there an additional solution to this aside from opening a different browser? We had more success with Firefox.

Has anyone else experienced this issue on a PC as well?

Thanks,
D.

Hey @dcampos2014,

Thanks for sharing that opening the link in a new tab worked for you—at the moment, this would be a suggested workaround. That said, can you confirm which version of LTI Pro this is?

Thanks,
Will

Thanks for the reply, Will! We’re using LTI 1.1.1

-Diana

Hey @dcampos2014 ,

What browser are you using? I suggest seeing if cookies were turned off by the user:

Thanks,
Tommy