macOS SDK on Xcode 12

Hello

While I have noted that your documentation states that your SDK is not compatible with anything above Xcode 10.3 I have just successfully built and run a project in Xcode 12.

Is there any reason I should not do this if it works - we have some dependancies we would like to include which need Xcode 11+ so ideally we will stick with this…

Thanks

Richard

Ah sorry - think i’ve answered my own question… While I appear to be able to build and run with xCode 12 it apears that I can’t code sign - I assume due to the nature of some of the libraries. Hmm

Hi @richard1, thanks for the post.

While it is possible to build/run your project with the SDK in Xcode 12, the SDK will not function properly within your application. We are still actively working on adding support for this, so be sure to keep an eye out for this in a future release. :slightly_smiling_face:

Thanks!