mediaCapturePermission doesn't work in Zoom web app

Hey @kanata.koyama to confirm if I understand the error you’re running into, does the following describe it accurately?

  1. You’re using the latest Zoom Web SDK to build a bot
  2. Requesting recording permission works when the host is joining from the Zoom Desktop Client (they have the Zoom program installed on their computer)
  3. Requesting recording permission does not work when the host is joining from the Zoom Web Client (they are joining the meeting through their web browser)

If this is the case, this is a known issue.

The Zoom Web Client does not yet support the local recording permission grant, which means the bot is not able to request recording permission from the host.

One alternative flow that might work is to use the Join Token for Local Recording to get recording permission automatically when the bot joins the call, instead of showing the host the dialog.

You’ll need to connect to the host’s Zoom account using OAuth and request this token before sending the bot to the call.

Alternatively, one option (which I’ve mentioned to you a lot recently :sweat_smile: ) is to use the API, which is a hosted API for meeting bots. Recall can automatically request the Join Token for Local Recording if it’s available, and fall-back to the manual request if it’s not, which will save you time building the additional integration.

@kanata.koyama I’ve just tested this, the prompt to host for permission should show up now.

  1. Host turns on auto cloud recording setting on
  2. Host schedules a meeting
  3. Host starts meeting
  4. Web recording bot joins meeting
  5. Web recording bot calls mediaCapturePermission API
  6. Host gets a permission prompt.

Do note that when the Web recording bot starts mediaCapture, there is no additional participant UI prompt “this meeting is being recorded”. This is expected as the “auto recording” has already prompted the user when they initially join the meeting.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.