Meeting 503970516 is not found or has expired

I consulted the following API and I get the following response
/metrics/meetings/{meetingId}I consulted the following API and I get the following response

After this, I tried getting information from the following API

Do you know why I got this error?

Which Endpoint/s?



Hey @itsupport,

What are you setting for the type query param? It defaults to live so if this meeting has ended you will get that response.

Try setting the type to past to get information about a meeting that has ended.

Let me know if this works!


Hi Tommy, thank you for supporting me,

The type of meeting is pass

Happy to help!

Have you tried:{meetingId}?type=past

The error is with the following API /meetings/{meetingId}

That works fine{meetingId}?type=past

Ah I see thanks. Can you confirm this meeting is apart of your account?

I tried and got the same error which makes me think it is because the meeting is not on your account.

    "code": 3001,
    "message": "Meeting 503970516 is not found or has expired."


Yes, this meeting is from my account.

This appears in the dashboard from the past meetings, please see the following imag

Hey @itsupport, thanks for the reply.

What account are you using to get an access_token or jwt? Can I have the email of that account?

I can see the host of the meeting ID (503970516) is not the same account that is calling the API.


This makes sense, but, I’m wondering how can I get access from the other meetings if I’m not the host, Maybe because I have an administrator role?
the email from the account that I got the token is JWT

Thanks @itsupport,

I believe the issue is because that meeting was deleted, so it does not return from the API /meetings/{meetingId} endpoint, but does return from /metrics/meetings/{meetingId} because it did exist at one point in time.

Check out this forum answer (it’s same question, but about webinars):

Let me know if that helps!