/v2/metrics/meetings returns code 3001, same UUID works in other calls

Hi there,

I get a “meeting does not exist” error for the following API call (same results whether using JWT or Server-to-Server OAuth apps):


The response is:

“code”: 3001,
“message”: “Meeting does not exist: g+5CdbmdQSW0L2tEVl21pw==.”

It most certainly is a meeting that does exist, because alll of the following API calls return successfully using the same UUID as above:


Is there something special about the /metrics API I’m not understanding? I’ve tried this with several of our recurring (no fixed time) meetings and get the same results.

I appreciate any help anyone can provide.


And just like that I solved my problem. I was setting the “type” parameter as an HTTP header, rather than a URL parameter. Simply adding ?type=past to the end of the /metrics API call fixed my problem.

Hi @shawnthomas
Happy to hear that you were able to solve your issue!
I encourage you to look into this post as well to understand the difference between passing the query parameter type past or pastOne

Hope this helps,