Meeting API "Get Meeting reports" shortcoming, "Create Meeting" access tracking

Good afternoon,

I am attempting to make it so that when my users are approaching the 100 API calls a day limit for the “Create Meeting” endpoint, a warning appears onscreen; I was hoping to rely on the “total_meetings” property returned by the “Get meeting reports” endpoint, but I have found that this is only accurate for meetings where my users and at least 1 participant have joined. i.e., today a coworker and I spammed the API and we got the expected error 429 but the report’s total_meetings value was only 87.

Is there an endpoint I can access that will tell me my usage against the “Create Meeting” endpoint?

Thank you!

@alexm, just a heads-up: the daily limit of 100 meetings applies to both creating and editing meeting transactions combined. For example, if you create 50 meetings and then edit those same 50 meetings, you’ll reach the daily quota of 100 meetings for that user. This limit is applicable to both API and web interactions. To track the number of meetings created or updated by a user, I suggest using the ‘meeting created’ and ‘meeting updated’ events for real-time updates.

Hi @ojus.zoom I am aware of that, fortunately I’m not making use of that second endpoint. Where can I find documentation on the “meeting created” event? Are you talking about webhook/websocket events?

Honestly, as a developer myself, I find it a little disconcerting that there’s an API with limitations in place but no easy way for development teams using that API to check their usage programmatically.

@alexm thanks for the feedback. We are currently working on the Marketplace API dashboard to address some of the concerns.

You can find the events for meeting created and updated here:

@ojus.zoom Thanks for the information. Can I suggest that the “number of meetings created by API” be reported as part of the HTTP response for the “Create meeting” endpoint?

@ojus.zoom a follow up:
I’ve noticed a few things that may be bugs with the “Get report” API endpoint:

  1. Even if the number of results exceeds the page size, the “next_page_token” is always an empty string
  2. Setting the “page_size” to anything is ignored; the page size returned is ALWAYS 30.
  3. The date range is always ignored as well.

1 Like