Meeting API SDK Secret orToken Wrong

When trying to create JWT token via Meeting API in our iOS app, we got an error in the API response MobileRTCAuthError_KeyOrSecretWrong.

The use case is that our mobile app users want to join a meeting via the meeting api but it failed now.

Need some help to troubleshoot this issue.

@charles.han ,

What version of the SDK are you using, and is this for iOS?

HI @chunsiong.zoom ,

We are using the latest iOS SDK. It worked till 10th August. I am wondering if there is a license limit for people to join the app via the Meeting SDK. Some other errors: .MobileRTCAuthError_KeyOrSecretWrong, .MobileRTCAuthError_AccountNotSupport, .MobileRTCAuthError_OverTime


@charles.han ,

On the latest SDK, you should not be able to enter your SDKKey and SDKSecret directly.
It has been remove in version 5.14.10 onwards

You will need to sign your JWT token separately using (SDKKey + SDKSecret) or (ClientID + ClientSecret), and pass it into the auth method.

If this still does not work, let me know, you might be encountering an issue with joining meetings hosted by external accounts

Hi @chunsiong.zoom ,

Thanks for you reply and we will try that. At the same time, we have created a new app in the Marketplace and use the client id and secret to get JWT, and it works for joining a meeting!

We think that it might be some limit in the old app. Do you know any thing about that?

Tried the SDK update, the old app still not work but the new app works.

@charles.han ,

If depends on how old the app is.
If the version of your “old app” is below 5.12.2, after 5th August 2023, it will stop working.

Hi @chunsiong.zoom,

When I say the ‘app’, it’s not our mobile app, it’s the Zoom App we’ve created in the Zoom MarketPlace. The differences for the two Zoom apps are:
Working app (new app created yesterday): can only see the App Credentials and it’s working for getting JWT.
Not working app (old app created a year ago): can see both SDK Credentials and App Credentials but both are not working for getting JWT.

@charles.han ,

Whatever you have mentioned is a bit odd, and shouldn’t be the expected behavior.
I’m glad that the newly created Meeting SDK App Credential is working.

For the “older” Meeting SDK App, you will be able to see SDK Credentials and App Credentials, here are their purpose.

SDK Credentials ( SDK Key and SDK Secret)

  • used to generate JWT for SDK Authentication.

App Credentials (Client ID and Client Secret)

  • used to OAuth access to Rest API.

For the “newer” Meeting SDK App, there is only App Credentials.

The App Credentials ( Client ID and Client Secret)

  • used for generating JWT for SDK Authentication
  • used for OAuth Access to Rest API

@chunsiong.zoom Yes, i feel odd as well because it worked fine before. Thanks for clarifying the usage for the credentials. That aligns with my understanding.

Is there any logs you can see from your end regarding the ‘old’ Meeting SDK App? I can DM you the details.

1 Like

Hi Charles, im also experiencing the same problem. I have sdk credentials, how ever it doesn’t work with the new version of the sdk. Im using android, im confused how jwt is being generated. Can you share what you encoded to generate jwt token? Thank you

@demlabus , please take a look here

Ive done that but it doesn’t really work. I used my sdk credentials to generate jwt .

@demlabus do you have a sample of the generated signature?