URGENT: SDK Auth failing in production

Description
Up until today our SDK auth (sdkAuth()) was working fine using clientKey and clientSecret. Today it is failing with the error keyOrSecretWrong. We have not changed anything on our end. This happened once in the past and we never found out why, but we were able to fix it by regenerating our client secret. Today, not even that solution is working so our app is completely broken for our users. Please get in touch so we can get this resolved as soon as possible.

Which iOS Meeting SDK version?
5.12.2 (4959)

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Call sdkAuth() with the given clientKey and clientSecret

Smartphone (please complete the following information):

  • Device: All
  • OS: tested on iOS 16, but assuming this is everywhere
1 Like

@jeremy.provost,

Sorry to hear about the behavior you are seeing with iOS SDK. Are you still seeing the same behavior? If so, to rule out the clientKey and clientSecret, can you use the sample IOS app to test if the credentials are working as expected? This will help isolate the root cause of the behavior you are seeing.

Let me know if you have any questions about this.

I have already validated that it is the clientKey and clientSecret causing the issue. We have a key/secret from another account and that works fine with the exact same code. Again, this code has been working for about 2 years and nothing changed except that this morning it started returning this error. To rule it out, I have also tried with jwtToken and that fails with tokenWrong. Has something happened to our Zoom app/account?

@jeremy.provost ,

That is strange, has anyone regenerated the clientSecret ? Also, are you using the clientKey and clientSecret from the Meeting SDK Marketplace APP type?

Create a Meeting SDK App

I wouldn’t expect the JWT token to work as iOS meeting SDK leverages SDK JWT token.

No one had regenerated the clientSecret. I validated that before anything else. Based on the one time this happened in the past, I then proceeded to regenerate but I get the same result with the regenerated clientSecret. Yes, this is a Meeting SDK app that has been approved in the Marketplace. I’m happy to share more details if you want to DM or email.

Now that we understand the problem seems related to that specific Marketplace Meeting SDK app, I’d suggest submitting a support ticket. You can submit a support ticket by filling out the form here. Be to include any device and crash logs you seeing produced to help expedite the triage process.

Enable iOS Log Feature

I opened a ticket there about 2 hours ago but I haven’t heard anything back. It’s #15903289 if you could have someone take a look please. We’re in a really bad spot right now. Thank you.

I have just uploaded a log file to the ticket as well.

@jeremy.provost ,
The ticket should be auto-assigned to a support agent. I will keep eye on it and have someone take a look if it is not picked up.

I still haven’t heard anything. Is there any way to escalate this?

We are getting a similar issue where the init is returning 1 instead of 0 for ios SDK. We are running 5.12 for sdk version

1 Like

I’m really sorry to hear that, but at least we know we are not alone. Did it just start over the past day for you as well?

yes, we upgraded to v5.12 last night and got it working but today we can’t seem to get the zoom meeting to start. We are using jwtToken to authenticate.

We are on the latest SDK (v5.12.2.4959). We have tried going back to the previous SDK (v5.12.0.4903) and that didn’t make a difference. We had been running successfully with the latest SDK since it was released.

Thanks Jeremy for letting us know about your issue as well. Please let us know if you find a solution. We will do the same. In the meantime, I think we might be switching to something a bit more stable than zoom.

Any fix for this issue? We have been suffering with this issue since last Monday. Thank you.

Our app is not affected, but seeing this kind of posts definitely doesn’t bolster my confidence

Eugene, Area you using zoom.us as domain or a registered domain. Thats the only thing I can think of that would be different.

We are using zoom.us. We’ve never used anything else.

For some reason we can put any random domain in there and auth will succeed, but then joining meetings doesn’t work.

@bluedomain and @uzir.thapa ,

Happy to help have this issue investigated. Can you open a support ticket and include the following information :

  • Account number
  • SDK key
  • An SDK log that has this issue
  • Developer Email Address:

After submitting the ticket, please share the ticket numbers here.