`meeting.created` missing `start_time`

Using this template helps us debug your issues more effectively :slight_smile:

Sometimes we receive events without (at least) the start_time field, thus our application fails because it expects to have it every time.
I don’t know how to reproduce it so this is mainly why I post here.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Webhook - meeting.created events

How To Reproduce (If applicable)
I am sorry I have no clue :frowning:

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
Here is the latest x-sm-trackingId received: Webhook_dc8ad861de544fbfac805cd1498b9045.
I bet that you will see that we responded with a 500 to in your logs :slight_smile:

When a meeting is set as a “Recurring meeting” with the recurrence set to “No Fixed Time”, I’ve observed that the Get a meeting endpoint omits the start_time field on the meeting object. Maybe a similar scenario is happening for your webhook event.

Thanks for the lead @MultiplayerSession. I tried but when I create a recurring meeting from Zoom the start_time value is now(). I didn’t find the “No Fixed Time” you mentioned, how do you do that?

Hi @benjamingrandfond,

Are you setting the pre_schedule field to false? Let me know if this might help.


Hi @will.zoom actually I don’t set anything, my app only receives events from Zoom when users create meetings.

Here’s a screenshot of the “No Fixed Time” recurring meeting option. When editing a meeting, it’s located after the “Topic” and “Description” fields and after the “Recurring meeting” checkbox as one of the options for “Recurrence”. The other recurrence pattern options are “Daily”, “Weekly”, and “Monthly”.

1 Like

Thank you verrrrrrry much @MultiplayerSession

Thank you for sharing your insight @MultiplayerSession!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.