Missing recurrence settings

Description
After sending my request, I get the following response: code 300, “Missing recurrence settings.”. So my question is why would that happen and are there any required settings fields for the recurrence array except for ‘type’ as described in the API. I am trying to create a recurring meeting with fixed time (type 8).

Error
code 300, “Missing recurrence settings.”

Hi, @tranvinhviet,

Thank you for posting in the Developer Forum. Are you able to share an example of the request you are sending ? This will help to identify the missing recurrence settings.

With Care,
Donte

// details for the meeting
$zoom_postfields = array(
“topic” => “$meeting_name”,
“type” => “8”,
“start_time” => “$s_time”,
“duration” => “$duration”,
“recurrence[type]” => 2,
“recurrence[repeat_interval]” => (int) $number_of_weeks,
“recurrence[weekly_days]” => “$week_day”,
“password” => “”
);

This is the array I send with the request through CURLOPT_POSTFIELDS. I hope it helps you to identify the issue. Thanks for responding!

Hi @tranvinhviet I’m not able to reproduce this, is there anything specific to the meeting which might help reproduce it?

Is this an instant, scheduled or Personal Meeting ID (PMI) meeting?

Best,
Donte

Hi @donte.S , it is supposed to be creating of a Recurring meeting with fixed time (type 8), according to https://marketplace.zoom.us/docs/api-reference/zoom-api/meetings/meetingcreate . I have successfully created a Scheduled meeting (type 2), but unfortunately no such success with the Recurring one. So I can hardly help you reproduce it since it hasn’t worked out for me, yet.
Thanks for the reply.

Maybe it would help if you can post an example of a request for that type (8) of meeting which has been successfully created by you?

Best regards,
Viet

Hi, @tranvinhviet,

Thank you for your reply! Here’s the example post used to create that request:

{
“topic”: “Example Post Type 8”,
“type”: 8, ← This value is of int type
“start_time”: “2021-04-25T12:00:00Z”,
“duration”: 30,
“recurrence”: {
“type”: 2,
“repeat_interval”: 3,
“weekly_days”: “4”,
“end_date_time”: “2021-05-19T12:00:00Z”. <— Include end-date to correctly generate occurrences.
}
}

Please test again with this request and let us know if the problem persist.

Best,
Donte

Hi, @donte.S

Thanks a lot for the reply and the assistance provided. It finally works now. I wasn’t sending the recurrence settings array correctly.

Best regards,
Viet

Greeting, @tranvinhviet,

Glad to hear that helped, it was a pleasure to provide support.

Kindly,
Donte

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.