MeetingSDK Initialization Error: Error : 1, InternalError:0

I’m experiencing ZoomSDK initialization error while running Zoom Meeting SDK sample in Android. Error:-
Initialization Error. Error code 1, InternalErrorCode: 0

Which Android Meeting SDK version?
Android SDK version : v6.1.0.22534

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Create General Zoom App as given documentation
  2. Enable Meeting SDK in Embed and download SDK
  3. Generate JWT using “ClientID” and Client Secret as follows:
    “appKey”: “C6ipyT1XTLycTAkQYXXXXX”,
    “iat”: 1719331876571,
    “exp”: 1719503967516,
    “tokenExp”: 1719503967516

JWT token Generated:

  1. Using this JWT token, I run the sample SDK
  2. See error: "Failed to initialize SDK: Error: 1, InternalErrorCode: 0

If applicable, add screenshots to help explain your problem.

Troubleshooting Routes

  • I’ve tried both way to create App: (1) General Zoom App, (2) Build Legacy App → Zoom Meeting SDK

  • I’ve tried adding multiple scopes like user:read:admin , view all user, etc.

  • In similar topic, somebody suggested to use init params while initializing zoom sdk in android : appKey, appSecret instead of JWT token. But I guess, these parameters are no more supported in latest SDKs.

Smartphone (please complete the following information):

  • Emulator : Pixel 4 API 28

@vivek.vashistha the iat, tokenExp and exp are not in proper epoch format

For instance the iat is in year 56453


Thanks. Now it works. I was setting time in milliseconds, whereas it is expecting in seconds