Microphone Turn ON problem

Microphone Turn ON problem:

App is developed on Angular 14,
using Component View of Meeting SDK
After join the Call When I Click on Microphone Icon to Turn on Mic, It is giving Following error in Consol

zone.js:1061 Unhandled Promise rejection: {type: 'INVALID_OPERATION', reason: 'Computer audio has been loading, please wait.'} ; Zone: <root> ; Task: Promise.then ; Value: {type: 'INVALID_OPERATION', reason: 'Computer audio has been loading, please wait.'} undefined
api.onUnhandledError @ zone.js:1061
handleUnhandledRejection @ zone.js:1086
api.microtaskDrainDone @ zone.js:1080
drainMicroTaskQueue @ zone.js:592
invokeTask @ zone.js:491
invokeTask @ zone.js:1661
globalCallback @ zone.js:1692
globalZoneAwareCallback @ zone.js:1725
zone.js:1061 Unhandled Promise rejection: {type: 'OPERATION_TIMEOUT'} ; Zone: <root> ; Task: Promise.then ; Value: {type: 'OPERATION_TIMEOUT'} undefined

Meeting SDK version is 2.9.7
Browser: Google Chrome Version 113.0.5672.93 (Official Build) (64-bit)

1 Like

@qasatti , is this issue in the latest version on Meeting SDK 2.12.2?

we were facing this issue on 2.9.7 after Upgrade to 2.12.2 we have the similar issue,
issues is resolved on desktop chrome with 2.10.1 but now we have mic issues on Mobile Devices Browsers specially on iPhone

which ios version - zoom web (SDK and the version on zoom.us) needs 15.4 or newer

are you able to resolve the issue on 2.12.2 (excluding mobile browsers)

Yes, it is resolved on Desktop browser after upgrading to 2.10.1

hi guys, I still have the same issue, how did you fix it ?

Which SDK and browser version are you using?

I tried multiple and all of them failing,

but did try:

Looks like it only happens if there is a Admit needed on the host side.
But I’m out of ideas right now…

It happens regardles of the browser, but I’m using Chrome Version 116.0.5845.97

@chunsiong.zoom Please help :slight_smile:

Here is the console log

and here is the app:

so it only works if the host Admits the client very fast.
If the host prolongs it for 5 sec, audio is broken.

I can see this error as well, maybe it can help:

Where you able to fix this problem? I had the same issue with you, if the host won’t accept the client within 5 seconds, the audio and mic is broken.

I havent tried the role 1 and zaktoken yet

Hi Qadeem,
Hope so you’re doing well, utilizing the Component View of the Meeting SDK, is encountering a microphone issue with an error indicating “INVALID_OPERATION” and a reason stating, “Computer audio has been loading, please wait.” Additionally, there’s another error of “OPERATION_TIMEOUT.” These errors often relate to asynchronous operations or delays. Ensure that the Meeting SDK is fully initialized before attempting to interact with audio features. You might want to check the sequence of loading computer audio, handling promises, and any potential timeouts. Also, verify if there are specific SDK initialization steps related to audio that need to be completed before enabling the microphone. Consider consulting the Meeting SDK documentation for version 2.9.7 for any specific guidance on handling microphone-related operations in Angular 14.

Hope so this will work for you!
Bryce June

@acaledesma No.
What I did is I’m using ^2.9.7 version, and that one is good.
Other newer version are not working.

Ohh thank you for the info, I might try that version. It’s kinda weird that it works on my local (for the latest version 2.18), but it doesn’t work on our staging environment, we’re using nginx without any CSP policy, so it should have work