Running Zoom SDK from an iOS Swift framework

My implementation is a simple app running an SDK. I wanted to add the Zoom SDK to my SDK, but the app crashes after MobileRTC initialisation without a clear reason. Can you help?

Hi idit,

Thanks for using Zoom SDK. Our iOS SDK should be compatible with Swift. We have a lot of users who is using Swift for development. What error code are you getting? Could you provide your SDK log file and the .crash file?

It would also be helpful if you could provide the following information:

A clear and concise description of what the question is.

Which version?
Knowing the version can help us to identify your issue faster.

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Go to ‘…’
  2. Click on ‘…’
  3. Scroll down to ‘…’
  4. See error

If applicable, add screenshots to help explain your problem.

Smartphone (please complete the following information):

  • Device: [e.g. iPhone6]
  • OS: [e.g. iOS8.1]
  • Version [e.g. 22]

Additional context
Add any other context about the problem here.


It is a bit complicated to explain, I did compile your SDK with our swift app successfully, but failed when trying to compile with our swift framework.
I can’t figure out how to upload the crash file here, I don’t have a log file

Hi idit,

Thanks for the reply. For the SDK log, you can find the way to enable it and retrieve it from here:

Once you have the SDK log, could you put the log and the .crash file in a shared drive(Like Google Drive), and share the link with us? If you do not want to share the log file here, you can send me a private in-forum message regarding this.


I’ve put the crash log here:
I can’t currently create a log file for the SDK since I moved the SDK to the app level, it’s not crashing anymore. If you still need it, I’ll go back and try again.
Another thing, now that the SDK is in the app level, I get an error when trying to upload to the app connect:
ERROR ITMS-90171: “Invalid Bundle Structure - The binary file ‘’ is not permitted. Your app can’t contain standalone executables or libraries, other than a valid CFBundleExecutable of supported bundles. Refer to the Bundle Programming Guide at for information on the iOS app bundle structure.”
I followed all the instructions here:
Can you help?

Hi idit,

Thanks for the prompt reply. I will pass this information to our engineering team and look into. Hopefully the root cause can be found in the crash file.

BTW, which version of SDK are you using? Are you using the device-only version(the one directly download from Github master), or the all version? You can find the version info here:


I’m using version number: v4.4.55130.0712. Downloaded from

Hi idit,

Thanks for your reply. Could you help to confirm the following:

  • MobileRTC.framework is shown in the General > Embedded Binaries, General > Linked Frameworks and Libraries, and Build Phases > Link Binary With Libraries
  • MobileRTCResources.bundle is added correctly and shown in Build Phases > Copy Bundle Resources?

After analyzing the crash log, it seems like the crash happens with this method:

- (void)onMeetingStateChange:(MobileRTCMeetingState)state

Can you try to comment out this method and see if the crash still exist? Could you share a code snippet of the implementation of this method?

Hope this helps. Thanks!

Regarding MobileRTC, I did the above and still get an error when uploading to store.
Regarding onMeetingStateChange, I don’t have an implementation for it. I’ll check again and see the logs.



Regarding the error I got when uploading to the store, it seems to be an issue with our CI system. When uploading from my Mac it works.
Thanks anyway,

Hi idit,

Thanks for the reply. Regarding the onMeetingStateChange delegate callback, it is a required callback that needs to be implemented, you may refer to the doc and the implementation in our demo:

Hope this helps. Thanks!

Hi Carson,

I’ll add that implementation. Thanks!

Thanks @carson.zoom!

Let us know if you have any other questions @idit.barash :slight_smile:


Getting this error while integrating Zoom SDK

dyld: Library not loaded: @rpath/MobileRTC.framework/MobileRTC

Referenced from: /var/containers/Bundle/Application/BB9FEB6D-61B8-4687-A914-2D7E04F07B4B/

Reason: image not found

@p.yashwanth I got this error when I forgot to add the SDK as an Embedded Binary

1 Like

Thank you for your email, I solved this problem by re adding the lib file and adding the SDK in Embedded Binary. Now it is working fine.

Thanks for the answer @idit.barash!

Glad it is working now @p.yashwanth :slight_smile:


Hi Team I’m facing this issue in sample code of Zoom iOS.Please help me

Hi pakistan.salman92,

Thanks for using Zoom SDK. Could you provide more info on the error you are getting? It looks like the ZoomAuthentication.framework is not our iOS SDK. You may find the iOS SDK here:, and please follow the instruction here to integrate the SDK into your app:

Hope this helps. Thanks!

You can implement like this : Zoom SDK Implementation in iOS Using Swift