Modifying Event notification endpoint URL after app disablement

API Endpoint(s) and/or Zoom API Event(s)
N/A

Description
A few weeks ago I created a new webhook only app for some development purposes and was able to get the webhook app integration working locally (using an ngrok URL while doing local development). Everything was working fine but after I finished with my tinkering I turned off the ngrok proxy on my local machine (which, in turn, disabled my assigned ngrok URL). That being the case, the webhook only app failed to verify the URL (as my local web server was no longer responding to revalidation requests) and my event subscription got disabled.

Now I want to start tinkering with my project again (which means bringing online a new ngrok session and, hence, a new randomly generated ngrok URL needs to be used for ‘Event notification endpoint URL’) but when I go into the Zoom App Marketplace, select my webhook only app, and go to the Event Subscriptions view, I am now unable to modify any of the values pertaining to the Event Subscription as all fields/toggles are greyed out (I can’t even disable the Event Subscription as a whole). The configuration page view is telling me to ‘Revalidate your endpoint URL’ but I am unable to revalidate that exact URL again (as it is provided by ngrok and transient) as the text-entry field is unmodifiable.

Futhermore, docs on the matter state that this should be a valid request.

I am not sure if this is a bug or if this is as-designed but I hoping you could advise on why this is happening and how I could go about fixing it.

Error?
Every aspect of Event Subscriptions pane (within the app’s ‘feature’ config page), is wholly unmodifiable; I can’t even delete the entire Event Subscription and start fresh.

How To Reproduce
Steps to reproduce the behavior:

  1. Create webhook only app
  2. Send data to transient url for development
  3. Validate app.
  4. Let webhook-only app fail enough to get disabled.
  5. Go to change event subscriptions URL and see that everything is greyed out.

@chefaustin, Are you the account owner where the app is created or do you have sufficient privileges to edit Marketplace App?

Sometimes if you have created Marketplace App When your account is not associated with any other account and then you are associated your Zoom account with another Zoom account then the App created previously will not be editable. If that is the case then you need to re-create your app.

Let me know if any thing is still not clear. Thanks

@freelancer.nak I am not the Zoom account owner where the app is created but I am the initial creator of the app (and, as expected, I have the ‘Zoom Developer’ role).

I only have one user account and it is certainly associated with a larger Zoom account/org tenant.

@chefaustin, then it seems that you created the app before associating your account as a sub-account to External Account.

That app still seems to be associated with your own account. You need to re-create the app.

1 Like

Thanks for the input. I’ve recreated the app again and will keep an eye on it to make sure it doesn’t succumb to the same issue as the previous one.

@chefaustin Welcome & Thanks. It will work fine until you will not access the app from a different account.

If any issue happened share that here.