No webhook events for production client ID for app in development

We are creating an OAuth App in the Zoom Marketplace. The app is still in Draft status (not listed). We’ve configured a webhook event subscription for a couple of meeting events (e.g. meeting.started, meeting.ended etc).

If a user uses the production client ID to connect the app with zoom then we’re not reliably getting webhook events. The webhook endpoint is working fine - it is validated (the validation request is going through). During our last test we received all webhook events for me (creator of the app) but none for one of my colleagues (he has the same app connected) - we tried for hours but to no avail. During a previous test we received events for both connected users. What could be the reason? Is it maybe connected with using the production client ID for a draft app? Will webhook events be delivered reliably for users connected via the production client ID when the app is listed/published?

We later decided to try with the development client ID and we started getting webhook events for all connected users. There are still some gotchas:

  1. The events start getting delivered roughly a minute after the user connects the app (and stop being delivered roughly a minute after the user disconnects the app). Events during this 1 minute period are “lost” (never delivered although the user is connected).
  2. There are duplicate events quite often.

Are these by design?

Also, is there any way to check webhook logs for OAuth apps? The Zoom UI seems to provide this only for Webhook-only apps. I tried via the getWebhookLogs API but got Authenticated user has not permitted access to the targeted resource. I have the marketplace_app:read scope - actually, if I remove the webhook_logs path suffix I get the info for the app which requires the same scope if the documentation is to be believed.

Ping. We are trying to list our app in the marketplace now and the production client ID is still not working (all good with the development client ID).

Our production webhook url is receiving messages fine - for example we do receive the “app_deauthorized” (when someones removes the app) or the “endpoint.url_validation” (used to verify the webhook endpoint). Bu that’s all we receive - we get no notifications for meeting related events, e.g. “meeting.started”, “meeting.ended” etc. (the webhook endpoint is verified, the app domain is verified, the production/development redirect/webhook URLs are different).

@elisa.zoom I see you helped resolve a similar issue here - Zoom not sending webhooks using production credentials for developer account

Can you please take a look?

Hi @plamen
Thanks for reaching out to us and sorry for the late reply here!
I will go ahead and send you a private message so you can share more information with me and I will take a closer look into this issue.

1 Like

To update this public thread, @plamen ended up deleting the webhook subscription and creating a new one, and after validating the production URL and authorizing the app using production credentials, this new webhook subscription worked for them.

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.