Not allow to start webinar from web. Web SDK 1.8

Description
when try to start webinar by Host the error : Not allow to start webinar from web. appear

Error
Not allow to start webinar from web.
errorCode: 3609
errorMessage: “Not allow to start webinar from web.”
method: “join”
result: “Not allow to start webinar from web.”
status: false

Which version?
SDK 1.8

1 Like

Hey @spawschool,

Sorry to hear you are having issues starting a Webinar with the Web SDK. Can you please share steps to reproduce the issue?

Make sure to follow the instructions here:

Thanks,
Tommy

1 Like

JoinZoom(WebinarID, Role) {
const timestamp = new Date().getTime() - 30000
const msg = Buffer.from(config.Zoom.APIKey + WebinarID + timestamp + Role).toString(‘base64’)
const hash = crypto.createHmac(‘sha256’, config.Zoom.APISecret).update(msg).digest(‘base64’)
const signature = Buffer.from(${config.Zoom.APIKey}.${WebinarID}.${timestamp}.${Role}.${hash}).toString(‘base64’)
const Data = {
signature: signature,
apiKey: config.Zoom.APIKey,
meetingNumber: WebinarID,
}
return Data;
}

mention that Role = 1

while that when try to join as attendee i join webinar successfully

1 Like

i just generate signature then try to join the error that “Not allow to start webinar from web” appear without any unexpected actions

1 Like

Hey @spawschool,

Does your Webinar have registration required turned on? If it does, try turning it off and seeing if that works:

Thanks,
Tommy

BodyContent = {
topic: Title,
// type: 2,
type: 5,
start_time: StartTime,
duration: 2,
password: “XXXXXXX”,
agenda: Desc,
settings: {
host_video: true,
panelists_video: true,
practice_session: false,
hd_video: true,
approval_type: 2,
registration_type: 1,
audio: “both”,
auto_recording: “local”,
// auto_recording: “none”,
registrants_restrict_number: MaxNumber,
enforce_login: false,
close_registration: true,
show_share_button: false,
allow_multiple_devices: false,
registrants_email_notification: false,
meeting_authentication: false
}
}

this is create webinar request

Thanks @spawschool,

Can you please also share the response body JSON so I can double check what was set by the API?

Thanks,
Tommy

{
uuid: ‘SuhZQcj7SDmZPKn6llXqCA==’,
id: 92742377920,
host_id: ‘xxxxxxxxxxxxx’,
host_email: ‘xxxxxxxxxxxxx’,
topic: 'xxxxxxxx,
type: 5,
start_time: ‘2020-11-15T05:00:00Z’,
duration: 60,
timezone: ‘Africa/Cairo’,
agenda: ‘xxxxxxxxxxxx’,
created_at: ‘2020-11-12T01:07:09Z’,
start_url: ‘https://zoom.us/s/92742377920?zak=eyJ6bV9za20iOiJ6bV9vMm0iLCJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiI0V3NjX0I0MFItcTdRS3JQLXljMllBIiwiaXNzIjoid2ViIiwic3R5IjoxLCJ3Y2QiOiJhdzEiLCJjbHQiOjAsInN0ayI6InFQdEFOa2Q5WTFIU0Z4OWlXZXBFcDhGei1fRVdNSjFGbTNFUzJHRVNqZGsuQUcuMXR5N0M1ZVZ0VTgwYUt6NG80Nk1jelljVHJtTncyUHhIVHZMc2hRYnU0V2VjczEtWGd6UHdSZm92dnJBa0hOTTRPSlhWa0tDRXE2M2ttQS5CUWZpY3Z2cWF2cld1c3ZjUUtKWXdBLjVFUzY0Mk1QVEVMRU16N2IiLCJleHAiOjE2MDUxNTA0MjksImlhdCI6MTYwNTE0MzIyOSwiYWlkIjoiX25FdGQ4YjlTV2VBWFVrQUlXVUJKdyIsImNpZCI6IiJ9.6VvpGtnFtURoko-OOC1GQPasREFlQM_aRlHSjE1zcuk’,
join_url: ‘https://zoom.us/j/92742377920?pwd=RWxOaWdlUmxMZ3J3NHlDWi9SMGcyZz09’,
password: ‘xxxxxxxx’,
settings: {
host_video: true,
panelists_video: true,
approval_type: 2,
audio: ‘both’,
auto_recording: ‘local’,
enforce_login: false,
enforce_login_domains: ‘’,
alternative_hosts: ‘’,
close_registration: true,
show_share_button: false,
allow_multiple_devices: false,
practice_session: false,
hd_video: true,
question_answer: true,
registrants_confirmation_email: true,
on_demand: false,
request_permission_to_unmute_participants: false,
global_dial_in_countries: [ ‘US’ ],
global_dial_in_numbers: [ [Object], [Object], [Object], [Object], [Object], [Object] ],
contact_name: ‘xxxxxxxxxxxxx’,
contact_email: ‘xxxxxxxxxxx’,
registrants_restrict_number: 0,
registrants_email_notification: false,
post_webinar_survey: false,
meeting_authentication: false
}
}

Hey @spawschool,

I was not able to reproduce this issue.

Make sure in your ZoomMtg.join object, you set the userEmail to the same email as the host of the webinar.

Thanks,
Tommy

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.