Not receiving webhook (event) to endpoint when joining meeting from Zoom Desktop App - Ubuntu


Currently, we are using zoom meetings API to create a meeting and to get the participant joined and the meeting ended information we are using the webhooks, and we have enabled event subscription under our JWT app. Also to our users, we are giving 2 options to join the meeting, one is via the web browser using the Web SDK and the second is via desktop client via redirecting them to the app.


When a user is joining the meeting via the desktop app (user is not a Zoom user created via user API) we are not getting any events payload to our endpoint (currently endpoint is in local so we are using the ngrok), but for the same meeting, if the user is joining the meeting via Web SDK, we are able to get the payload into our endpoint.

So my question is why this is happening with the desktop app and not with the Web SDK? is there any restriction on using webhooks? and also sometimes webhook called are being delayed so it is expected behavior or we will always get the payload in real time

Which App Type (OAuth / Chatbot / JWT / Webhook)?


Hi @chiragk

I hope you are doing great, I just wanted to reach out to you to confirm if you are still experiencing this issue or if you were able to resolve it??
Let me know if you need any help from us!


Hi @elisa.zoom

After your comment, I tried joining multiple meetings and now I’m getting the webhook payload after joining the meeting from the Zoom desktop client (Ubuntu).


Hi @chiragk

Thanks for reaching out back to me and for confirming that this is not an issue anymore.
Feel free to reach out back to us if you encounter this same error again.