Not receiving webhooks

Description
We are using the recording completed webhook to get recording information and to download recording for our customers. Our app was just approved and everything was working fine. However, we are no longer receiving calls from the webhook.

Error
We do not have any errors because we are not getting the calls

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth app

Which Endpoint/s?
Recordings Completed event for a webhook

  1. Are you using the Production URL for your event subscription (versus the Development URL)?
  2. Have you checked the Verification Token matches?
  3. Have you opened Zoom Marketplace and viewed the Webhook Logs for your app (if they are being generated, they will display in that list).

Thank you for responding.

  1. Yes we are using the Production URL.
  2. We are not getting a call so we are not getting a Verification token to check.
  3. The Webhook Logs are empty.

Hey @christian1,

We are aware of some webhook issues.

Please see this thread:

Thanks,
Tommy

Hello @tommy,

Thanks for the information. How should we proceed from here? We can send you which webhooks we are missing or should we wait till we hear more in the other thread?

Thanks

Hey @christian1,

Yes, please send us which webhooks are missing, when.

Thanks,
Tommy

@tommy Here is a list meeting ids and times we did not get webhooks.

Meeting Id : Time
241-608-7026 : Mar 27, 2020 09:42 AM
785-617-490 : Mar 27, 2020 10:56 AM
409-016-951 : Mar 27, 2020 11:04 AM
805-977-562 : Mar 27, 2020 11:05 AM
911-578-397 : Mar 27, 2020 11:58 AM
795-297-538 : Mar 27, 2020 12:42 PM
521-683-316 : Mar 27, 2020 01:20 PM
133-882-902 : Mar 27, 2020 01:32 PM
687-059-228 : Mar 27, 2020 02:18 PM
523-422-875 : Mar 30, 2020 09:50 AM

Thanks @christian1,

We are looking into the issue and will get back to you. (ZOOM-147991)

-Tommy

Thanks Tommy. As a heads up, we serve a large amount of real estate companies. People are trying to still move to New places but agents cannot show houses. You will be helping a lot of people to continue in their life progress but helping us to reach a solution here. I’d estimate we serve 30% of the real estate industry and are adding a lot more. Much appreciation.

Hey @christian1,

From our logs we see that the webhooks were indeed sent, and that we received a 200 OK response back from your server.

Thanks,
Tommy

Thanks Tommy. Travis, looks like a problem exists on our side?

Let us know if you find anything in your logs.

Thanks,
Tommy

@tommy We are still not getting any of these webhooks. Can you see what url they are going to? We have the production url set up but the first thing it should be doing is logging that we received the webhook and we have not seen any come in.

Hey @christian1,

What is your endpoint URL? Also please make sure you are sending back a 200 OK response once you receive the webhook or Zoom will stop sending them.

Thanks,
Tommy

Thanks Tommy. We will confirm.

@tommy they should be going to

URL

https://www.wellcomemat.com/api/webhook/zoom.php

At least that is how it is set up in the app.

Hey @christian1,

When making posts to that endpoint, I am seeing an internal server error.

Can you share your endpoint code that receives webhook requests so I can debug? Please also check any fire wall settings that may block post requests to your endpoint.

Thanks,
Tommy

Hello @tommy ,

You received that internal error because there was no recording files in your request. We have fixed it so it will now respond with a message.

We did get a log when you made that request on postman, but we are still not receiving logs from the webhooks though.

Thanks,

1 Like

Hey @christian1,

Thanks for letting me know my test request worked.

We are looking at the logs on our end and will get back to you. (ZOOM-149070)

Can you private message me a meetingID of the recordings that aren’t sending?

Thanks,
Tommy