One app receives recording.completed webhooks, another app does not


We have two account-level OAuth apps registered, one for our development system and another for our production system.

In both app registrations we have enabled the recording completed event:

We receive recording.completed webhooks ok in our development system, but not our production system. Our production system does receive other webhooks ok. We haven’t checked exhaustively, but it seems our production system receives all webhooks ok except for recording.completed events. Yes, we are waiting long enough, over 12 hours.

We have tried toggling the event subscription setting in the production app’s registration and also tried reconnecting our test zoom account to our system, but our efforts to find a fix are not working.

Both apps have this scope enabled:

We are still not having any luck figuring this out.

Hi @RobertYeager, for some clarity, does your production environment receive other webhooks from Zoom? Or is it just this app which is not delivering requests. Can you check the webhook logs from this app and see if they are firing but are not delivering?

I was clear that our prod system does receive other events ok:

Do you mean Zoom has an outbound webhook log we can check? If so, where is that?

Hey @RobertYeager,

Can you try reinstalling your production OAuth app and see if that fixes the issue?

Currently if you create a Webhook-only app, you can see the outbound webhook logs here:


Hi Tommy,

What does that mean? This is a registered OAuth app. We have your provided API keys. We enable scopes and features like webhook events. Customers connect their accounts via OAuth .

There is no “installation” in any of this.

This is not a webhook-only app.


Hey @RobertYeager,

To clarify, can you try uninstalling and reauthorizing your OAuth app to see if that fixes the webhook issue?


That looks to be equivalent to disconnecting our account and reconnecting via OAuth, which generates a new OAuth access token. That did not help.

Can anybody on your team help to determine if your system is attempting to send our system those events? This seems to be your bug, as our system is receiving other events just fine.

Hey @RobertYeager,

Our engineering team is looking into the issue. (ZOOM-147991)

I will get back to you with updates.


Thank you, Tommy. Looking forward to getting this to work.

1 Like

You are welcome!