OAauth App not receiving webhooks

Description
My OAuth app listens to the “All recordings have completed” event, but I’m not receiving that webhook, either in development or production.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Oauth

Which Endpoint/s?
webhook is https://marketplace.zoom.us/docs/api-reference/webhook-reference/recording-events/recording-completed

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. I created the OAuth app and added it to my Zoom account.
  2. I started a meeting on my Pro account, and recording was turned on.
  3. The webhook was never received, however I do see the downloads in my Zoom account. I’m also able to view meeting cloud recordings through the API.

Additional context
I did see the webhook being hit when I was using a JWT-only app.

Hi @2shobhitsriv6,

Thanks for reaching out about this, and happy to help.

A few things to check:

  • Can you confirm you’ve installed the OAuth App locally for the user/account you’re testing/starting a meeting with?
  • Can you ensure that the webhook endpoint you’ve provided for receiving Zoom payloads at is publicly accessible and returns a 200 OK response upon receipt of payload?

Let me know—thanks!
Will

Hey Will, thanks for getting back to me! I took a second look at my callback url, and realized I had a typo in the route :expressionless:. It worked when I fixed the typo. Thanks!

Ah, I see! Glad that fixed it. :slight_smile: