OAuth Allow List for desktop app

Before Creating a New Topic:

If you’re experiencing unexpected Video SDK behavior please search the forum with relevant keywords (e.x. error message) and follow the guidance outlined in those posts. Please also leverage the following support links:

A clear and concise description of what the question is.

Which Windows Meeting SDK version?
Knowing the version can help us to identify your issue faster.

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Go to ‘…’
  2. Click on ‘…’
  3. Scroll down to ‘…’
  4. See error

If applicable, add screenshots to help explain your problem.

Troubleshooting Routes
The troubleshooting attempt types you’ve already exhausted, including testing with the appropriate sample app (found on Zoom · GitHub).

Device (please complete the following information):

  • Device: [e.g. Dell XPS 13]
  • OS: [e.g. Windows 10]

Additional context


I developed a desktop app that integrates with Zoom meeting SDK
I used to put Oauth Allow list like this one : zoomAuth://silexpro.com and it used to work and redirect it successfully to my app.

but now when trying it it gives me zoom that this link is invalid .

How can I fix it ?

Thank you

Hi @samantha2
Thanks for reaching out to the Zoom Developer Forum
Is your app published in the Marketplace? If so, could you share the name of it with me.
Also make sure that the redirect URL (dev or prod) matches the oauth allow list

Dear Elisa,

No, my app is not published in the zoom portal. And I tried now to put same redirect URL in the dev and prod fields as well as the allowed list and it still not letting me put the URL :“zoomAuth://silexpro.com” in the allowed list but it’s saved in the dev and prod fields. and when trying to get the Access Token it gives me the error invalid redirect URL .

Thank you for your help


I see what you mean.
the URL needs to be a valid HTTPS secure URL

But this used to work before I am working on a desktop application. So I can’t have a web link .
I used to make the access token be redirect in the registry to my desktop app and was working until 2 days ago.

How to solve this?

Kind Reminder,

What should we put as an allow list for a native application with no backend server now ?

@samantha2 , could you take a look at pkce auth?

This is specifically for client apps without backend server

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.